[Closed] Can't get to History


#1

By default Brave turns off the menubar, but without the menubar there is no way to access History.

I’ve found a workaround: Turn on menubar, show History, Bookmark the History page (on the Favorites Bar), then turn off menubar.

But really, this should rather obviously be built-in to the “three dots” menu at the right.


#2

Hi @Steerider. You can use keyboard shortcuts to enable clear browsing history. Pressing Ctrl+Shift+Del on Windows and Cmd+Shift+Del on OS X. This brings up the clear history modal where you can choose to delete browsing history


#3

Or you can use Ctrl+Y to open History page.


#4