Clicking on PDF links will prompt to save file instead of allowing to open it

When clicking on a link pointing to a PDF, I’m not offered the choice to open and view it.
Instead, Brave immediately opens a dialog box to select the folder to save the document (which works fine, but is not the desired behaviour).
Issue is with Brave only (works es expected with Chrome, Edge and Firefox, both of which ask me what I want to do, including open it with the default PDF reader).
In Brave Settings I can only specify if I should be asked or not for a download folder (the feature works fine, in both Y/N cases).
There is a missing behaviour here to open the PDF file (e.g. within Brave or externally) besides downloading it.
I’m using Brave version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (64-bit) on Windows 10 Professional.

In Settings: brave://settings/content/pdfDocuments

it states: “Download PDF files instead of automatically opening them in Brave”

If that switch is OFF, then the PDF file will automatically be opened.

But, it sounds like you are requesting a feature change, such that a pop-up window or dialog box that provides options for both (not either or):

  • Save PDF file to . . .

  • View (Open) PDF file

So, you might adjust / include Categories and Tags, such as:

Brave Feature Requests > Desktop Requests > feature-request

if, that is, you can edit your post and do that?

Also the website can also dictate whether its a pdf within the browser or opened as an attachment.

Well, thank you @289wk for your guidance to find this setting ! I didn’t realise I would have to unfold twice even more advanced settings to uncover this one.

It appears that, whatever the value of this setting, i.e. OFF (which it was set to) or ON, the same behaviour appears : the Save As dialog box opens. The PDF never “automatically opens in browser”. So that sounds now like a bug on an existing feature, or am I wrong ?

I was initially simply hoping to have the same behaviour than in Edge, Chrome and Firefox, which didn’t appear unreasonable as an expectation to me. Of course, if the buggy behaviour is corrected, I certainly can live with the “automatically opens” behaviour.

PS: I tried to categorize and tag this post/thread but the keyword ‘bug’ isn’t allowed for the category Browser support Desktop support ?

With the aforementioned switch turned OFF, if you then do this: Any intention by Brave to allow opening of pdf files based on File Type specified in Windows? - #15 by davidlane

i.e., choose to ‘Always open with system viewer’; AND, if Brave is defined as your PDF viewer in Windows; does it work then?

If not, can you provide a link to an example where it doesn’t work?

Maybe take a swing at these:

Dear @JimB1 and @289wk , thanks for your replies and suggestions.

In a nutshell : whatever default PDF viewer is assigned in Windows, the same ill-behaviour is observed when trying to open a PDF within Brave.

I tested with following settings for the default viewer defined in Windows 10 : Foxit PDF Reader (which is the one I’m always using), Adobe Reader, Edge, Chrome and even Brave.
With each of these five scenarios :

  1. opening a PDF file on my computer does use the default defined viewer (as expected) when double-clicking the file in Explorer (or Total Commander afaic) – and yes also when Brave is defined as default PDF Viewer, Brave opens nicely and displays it

  2. opening this PDF on Internet (found as the “Tarif Green Fees 2020” on this page) either with Firefox or Edge or Chrome opens a (same) dialog box asking if I want to (a) open it in the browser or (b) use the default system viewer or (c) save it locally.
    → selecting (a) always works, i.e. it can be viewed within the browser
    → selecting (b) also always works, i.e. it will launch the defined default viewer whatever was selected across the 5 scenarios, in other words each of the browsers will also launch Brave to display the PDF when defined as default viewer and that shows fine
    → selecting (c) always works (and is sadly the only behaviour offered in Brave)

  3. opening that same PDF on Internet with Brave will just not open it and immediately prompt the Save As dialog box, whatever the default viewer (all 5 tested, including Brave itself)

Note: When delving into Chrome settings, I have found that the behaviour around the PDF
documents has a similar approach but via a pair of radio buttons: either “Download PDFs” or “Open PDFs in Chrome” which results the correct behaviour here.

Note 2: oddly enough, whatever change I apply to the default viewer in Windows, when clicking on the PDF link the Save As dialog box opens but it is always “Foxit Reader” that is identified as default file type (should that not change with systems settings change ?)

Does this clarify the true oddity of my situation with Brave, which otherwise works fine ?

1 Like

Jim, to answer your question more specifically, no, even when Brave is defined as default viewer at Windows level, the link doesn’t open the PDF in Brave. But opening any PDF on the PC however works fine. Or opening that same link from Firefox and selecting Brave or Chrome as external viewer also.

Thank you for the details!

I did a search . . .

Looks like it requires a bit of study, but the following may work.

Author Christoph Kolbicz (in Switzerland) of SetUserFTA utility: member who used it:

What I mean, is, you may find the clue in his writing or even the utility.

Thanks a lot @289wk for these researches and shared links.
I’ve been reading those sources carefully and I have two remarks:

  1. true, those are indeed interesting clues but imho the utility would not address the issue and I’m hesitating to fiddle with these specific registry settings, tho I could back it up first. Especially as at system level (Windows 10 settings) the behaviour is as expected : the setting works and changing the setting also works.
  2. Besides, I’ve tested the issue on two other PCs and exactly the same ill behaviour of only Brave happens, while all other browsers behave as expected – how come we can’t consider this as a bug in Brave that requires code correction in Brave ?

Thanks for your insights on this.

Have an example web site that opens the pdf differently to Chrome?

Hi @fanboynz, (please see my extensive explanation of july 27th).
The link I gave was to this PDF , which can be found on this page if you click on “Tarifs Green Fees”.

The trouble is not that it opens differently, but it doesn’t open AT ALL, but instead asks to save it (which is not the desired behaviour, nor is it consistent with the Brave Setting about PDF documents). That same PDF link however indeed opens nicely in the browser in Chrome, Firefox and Edge.

brave://settings/?search=save+each and toggle that. refresh the page, and it’ll download like Chrome

Sigh. Allright. Did it again. But as as computer are predictable, same happened again.

When setting is ON : I’m being asked where I want to Save the PDF (it doesn’t OPEN it)
When setting is OFF : I’m not even being asked, it downloads it straight (to Downloads folder) and that’s it.

I’m sure you’re genuinely willing to help but it looks to me you were rushing through the input/description I gave, and did not understand the issue : the PDF will not open and show in Brave browser when clicking on the PDF link.

In Chrome when clicking the link it is opening the default Windows 10 PDF viewer (so does Edge and so does Firefox which asks first). And guess what, when I say the PDF viewer should be Brave, then Chrome will launch Brave and show the PDF in it ! But Brave just can’t seem to handle it (for me at least).

Have you tried yourself to open the PDF I linked in Brave ?


On the chance that you intended to reply to me . . .

Your website webpage (PDF file link) of interest:

Using a New Window (and test with a New Private Window, too) . . . Immediately to the left of the URL address (your PDF file link), what I find is a circular icon that includes an Exclamation Point symbol. I right-clicked on that icon.

You should get a pop-down window listing various Brave Security -and/or- Shield settings, some of which may be currently BLOCKED. In particular, maybe ALLOW these two:

Screen Shot 2021-08-02 at 9.50.12 AM

Screen Shot 2021-08-02 at 9.50.24 AM

PS. I only get the Download - but I prefer to view all downloaded files, by way of their parent application (such as Adobe Acrobat Reader for PDF files). And, I did test both “New Window” and “New Private Window”.

@AlterMind could you please check whether you can open any of the .pdf files on, I might have something in mind?


Maybe try some other PDF readers.

XoDO: “

XoDO extension:

Beeline Reader: “

Beeline Reader extension:

How can I add extensions to Brave?

Hi @Rethanis thx for the reaction. Yes, your link brings me here:
and I confirm I can open ALL these PDF files within Brave (eyes getting wet now)
What have you got in mind ?

Hi @289wk ! Thanks for bouncing back to me. The dropdown I’m getting looks like this:

then when going into the Site settings, I can confirm that:
JavaScript is ; Allowed (default)
File editing is : Ask (default)

The latter is consistent with the PDF Documents setting which requires to ask me where to download.

EDIT: same behaviour for New Window and New Private Window.

Take my words with a grain of salt.

When I take a look at the .pdf you’re struggling with (I confirm I can’t open it in Brave as well), I notice its name contains a lot of special characters, such as spaces and -, which Brave might fail to interpret for some reason, thus failing to open the file directly into a new window. If that is the case, again take my words with a grain of salt, we could claim it’s a bug with Brave as other browsers successfully interpret such names and act accordingly.

Do you happen to have access to other .pdf files with such “weird” names, so we could take a deeper look into this?