Claiming BAT grant did not work from mobile

Description of the issue:
I am using Brave on an Android device. A couple of days ago, when I opened the browser, I noticed that BAT support was added. I clicked through to create my BAT wallet. I think it succeeded but I am not sure where I can confirm that. I just created the wallet, I didn’t add any funds to it. Today I saw there was a token grant, and I tried twice to claim it. Both times the progress wheel kept spinning and claiming the token didn’t complete.
Steps to Reproduce (add as many as necessary):

  1. From the address bar, clicked the triangle which had a notification about the token grant
  2. That popped up a small window to claim
  3. After clicking claim, it didn’t complete

Also,

  1. From the home screen there was also notification of the token grant
  2. I clicked claim from there and it also didn’t complete. Just the progress wheel kept spinning.

Actual Result (gifs and screenshots are welcome!):
Token was not claimed

Expected result:
Expected to claim the token

Reproduces how often:
I only tried twice.

Brave Version(about:brave):
1.0.91

Reproducible on current live release (yes/no):*
Yes

1 Like

Same problem I have described in this thread. Apparently this is a reoccurring bug and is not fixed.

@CarlK Would you please name the device and OS you have encountered this problem with.

1 Like

Not that it helps you CarlK -
I had a free token a few days ago and managed to claim it fine on my device.

48 16

What would happen if you either updated the app at a later stage or reinstalled from playstore? would you lose the grant?

1 Like

Wallet backup is only support on desktop but not on mobile device. So if you delete and reinstall Brave on mobile device your wallet will be lost.

1 Like

Hope I dont face this problem when Brave push out an update in the playstore…

1 Like

Since you can also not add real money to the wallet on mobiles your losses would be effectively zero.

1 Like

The problem occurred on a Google Pixel 3 running Android 9, build PQ2A.190405.003

1 Like

Same issue here. On Oxygen OS 9.0.4.

1 Like

The notification appeared again today, and I tried to claim the token again. This time it worked.

1 Like

Mine is also stock but with join rewards on mobile

1 Like

Same problem here …

Brave version 1.0.91
Android 9; Pixel 3 Build/PQ2A.190405.003

Same problem, clicked claim. Waited a few minutes and nothing happened. My screen turned off and the notifcation with grant was completely gone.

Note 8, Android 9

Same problem. Got the notification twice on Facebook, both times claiming shows a weirdly laggy loader for a while and nothing happens. No way to retry either.

OnePlus One, ArrowOS (Android 9).

Same issue here but on desktop. Latest version of Brave running on Windows 10. Went to claim and would not allow. Now I am no longer to even see the the claim button, afraid I lost my grant.

I’m having the same issue, Galaxy Note 8 Android 9. I’ve had multiple notifications to claim my BAT token and each time it just loads for a minute and fails. I’m afraid I’ve lost at least three claims so far :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.