Claim Free Tokens claims server is not responding


#1

I use Brave payments on two computers. One is Windows 10. One is Ubuntu.
On the Windows 10 computer, “claim free tokens” worked fine.
On the Ubuntu computer, it keeps saying that the server doesn’t respond. I’ve tried several times each day in the 5(?) days since both computers told me I could claim some free tokens.

The browser says it could be a network connectivity problem, but it’s not. I’m connected just fine. Brave can browse the web just fine.

In addition, I pointed Brave through a HTTP proxy so I could inspect the traffic. Here’s what I saw. (I’ve X’ed out some sensitive information.)

REQUEST
PUT /v1/grants/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX HTTP/1.1
Host: ledger.mercury.basicattentiontoken.org
Connection: close
Content-Length: 54
Accept-Language: en-US
Accept-Encoding: gzip, deflate
content-type: application/json; charset=utf-8
user-agent: Brave/0.22.721 Chrome/66.0.3359.170 Muon/6.0.12 Linux x64

{“promotionId”:“XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX”}

REPLY
HTTP/1.1 403 Forbidden
Server: Cowboy
Connection: close
X-Rate-Limit-Remaining: 45
X-Rate-Limit-Limit: 50
X-Rate-Limit-Reset: 1528480060
Content-Type: application/json; charset=utf-8
Cache-Control: no-cache
Vary: accept-encoding
Date: Fri, 08 Jun 2018 15:47:04 GMT
Via: 1.1 vegur
Content-Length: 77

{“statusCode”:403,“error”:“Forbidden”,“message”:“must first request captcha”}

So the server is responding & has a useful error message that the client could have displayed.

But I think the bug is that Brave (on my Ubuntu machine) never showed me a captcha in the first place. (Brave on my Windows 10 computer did show the captcha, & I was able to claim tokens there.)

The two browsers are Brave-Sync’ed together, though I was under the impression that Brave-Sync doesn’t join the BAT/Uphold/whatever accounts.


#2

@deadhacker please update to 0.22.727 and try again on the Ubuntu machine.


#3

Done and Fixed.
Nice!


#4

Great! Glad to hear it @deadhacker. Going to close out this thread, please feel free to open a new one for any other issues/questions :slight_smile:

Best,
Lauren


#5