Citrix protocol handler (*.ica) - Prompts for download - How to remove

Description of the issue: Initiating a Citrix application from a Citrix Workspace site always prompts for downloading a file.
How can this issue be reproduced?

  1. Use an Ubuntu Linux box
  2. Go to your (corporate) Citrix site, log in and click on a Citrix application shortcut
  3. A download dialog will appear – This should not happen
  4. Save the payload to a file (*.ica)
  5. Execute the file (by clicking on the downloaded item in the footer bar of the Brave browser)
  6. On Ubuntu 18.04 a “Open With” Portal dialog pops up; select the “Citrix Workspace” application to run the ICA file

Expected result:

At step 3, Brave should directly pass the ICA file to the Citrix Workspace desktop application. That would initiate the Citrix session to be started automatically.

No steps 4 to 6 should be necessary.

Brave Version( check About Brave):

v1.46.144 (Dec 14, 2022)

Additional Information:

This topic was brought up similarly in Oct 2019 at Tel protocol handler - Prompts before opening default app - How ot remove

1 Like

Hi there @bittner does the download dialog prompts if you click on a shortcut created on a different chromium browser like Chrome?

If it does, try creating a new profile on Brave by going to Main menu --> Create a new profile and from there create a shortcut for your application to see if the issue persist.

Let me know if that works.

I don’t understand that portion. With “shortcut”, do you intend an item that is available on the Citrix Workspace, i.e. the thing that you click on, or the ICA file that gets downloaded afterwards? If it’s the latter, that works without any prompt in other browsers. Only Brave behaves that way, other browsers that I have (Firefox, Chrome, Opera) process the downloaded ICA file transparently.

I’m not sure I could answer your question.

The behavior here should be that it asks you if you want to open the file with Citrix Workspace (protocol handling), with the option to “always” open those type so files [with the desired program].

May have something to do with the specific file type — I’ll reach out to the team about this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.