Checkbox is not visible when no default styling is applied to pages


#1

Description
Default input type check html styling is not applied to elements and checkboxes are not visible on pages

Steps to Reproduce
Open Brave on MacOS latest version
Navigate to any site which contains a checkbox without styling

Actual result:

The checkbox is not visible with no styling applied.

Expected result

Brave should have a default styling for checkbox as many sites render irrationally and the checkbox cannot be seen.

Workaround
Manually add styling to websites that have checkboxes so that I can complete forms.

Reproduces how often:

Every time.

Specs

Brave: 0.23.31
V8 6.7.288.46
rev 3148ace|
Update Channel Release
OS Architecture x64
|OS Platform|macOS|
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 67.0.3396.103


#2

Works on Windows

@LaurenWags could you check on mac?


#3

@Ricksor1987 does your HTML provide a checkbox on Chrome? When I tried your HTML code using both Brave and Chrome it didn’t work. The below code did work on both Brave and Chrome:


#4

@LaurenWags I’m not sure about chrome as I don’t have it on my mac. I can however confirm Firefox and Safari don’t do this. It also happens on many websites.

Current workaround is I manually add css styling to pages which have checkboxes.

Becomes a problem on many pages with js design approaches.

Here is an example on slack for clarification


#5

Hi @Ricksor1987

Thanks for that example - I’m not seeing that issue with the default settings.

When you go to that page in slack and click on the lion icon, what are your shield settings? If you could post a screenshot of the settings for that page that would be helpful.

Thanks,
Lauren


#6

This is a known bug with Mojave (which is still in public beta; you should always specify OS version when reporting bugs):


#7

That checkbox renders fine in Firefox:

Still broken in brave though


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.