Check marks on website icons in top sites widget

When there is no internet connection, Brave will notify you when the page becomes available. This appears as a check mark on the website icon in the top sites widget on the new page tab.

But these check marks don’t go away once connection is back and the pages have been viewed. Is there a way to remove them?

1 Like

Hello there @Sluggo please accept my apologies for this inconvenience. In order to investigate further, I will require the following information:

  1. Description of the issue:
  2. Steps to Reproduce (add as many as necessary):1.2.3.
  3. Actual Result (gifs and screenshots are welcome!):
  4. Expected result:
  5. Reproduces how often:
  6. Mobile Device details and Brave Version( check About Brave):
  7. Additional Information:

Be waiting for your response.

Hi @Kevin_cc

Step one: be offline

Step two: open a website. Brave tells you that it will display the page when there’s an internet connection

Step three: go online

Brave notifies you that the page is ready by displaying a check mark on the top sites icon:

Step four: check mark won’t go away

Expected result: check mark disappears

Reproduces: every time

Phone: Samsung A13

Brave version:

1 Like

Hi again @Sluggo could you please try deleting your cookies from the app to see if the issue is solved?

  1. In Brave, open the main menu, then Settings --> Privacy. Note: You can also select Menu --> History --> Clear browsing data.
  2. Select Clear browsing data.

Let me know if that works.

1 Like


That ends up removing all the top sites completely and they need to be set up again.

@Kevin_cc Also, when adding that same website back to top sites, the check mark is still there.

1 Like

Hi again, in this case try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Be waiting for your response.

Yeah it still happens there, too.

I’ll just live with the check mark never going away, lol.

1 Like

@Sluggo do you have a different Android device where you can install Brave to see if the issue persist there?

Yeah this happened on my old phone, too. I just never bothered asking about because I figured I’d eventually figure it out.

Are you unable to reproduce this? How do you get the check mark to go away?

1 Like

@Sluggo on a Samsung A21S the mark goes away once loading a website when it becomes available. Does changing the connection type make any difference? Like switching from WIFI to mobile data or viceversa?

Hiya. No, it makes no difference.


Some more info…

If I go back online and retrieve the page, then go offline again I am able to view an offline, downloaded version of the page.

Perhaps brave isn’t removing the saved offline version of the page it downloads once it goes back online and I view it?

1 Like

Hi again, could you please go to brave://flags/ > search Default offline page for PWAs > enable it > relaunch Brave, let me know if that changes anything.

OK, I seem to have figured this out and I feel dumb and I’ve probably wasted your time.

Your first suggestion to clear browsing history is the correct one. I had been doing that, but apparently wasn’t going back far enough in time to the date the offline page was stored.

I’m still not sure why simply going to the page again doesn’t remove the check mark for me, but at least I can get rid of it.

1 Like

@Sluggo thanks for sharing that information.

If you encounter the same issue again or have other concerns please let me know or create a new community post in order to further assist you.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.