stopped working after updating to the latest version



After getting the latest Brave desktop browser updates (0.19.131) I noticed I can no longer log in It used to work before the update.

On Google Chrome, it loads just fine, but on the latest version of Brave, it’s clearly not working properly: (1) takes forever to load the dynamic content (2) doesn’t even load the login form on the homepage i.e. username/password fields never load.

Brave: 0.19.131
rev: da2f34787e51eb44190a7a77249e100fb2368306
Muon: 4.5.36
libchromiumcontent: 63.0.3239.132
Node.js: 7.9.0
Update Channel: Release
OS Platform: macOS
OS Release: 17.3.0
OS Architecture: x64


I thought this was just me but can confirm this recently started happening to me as well. I tried disabling shield too. The entire site is unusable and dev tools don’t seem to show any issues.


Same here. Chrome works fine, latest brave - nothing. Just keeps spinning.

#4 doesn’t work for me either,

Brave 0.20.46
V8 6.4.388.41
rev 5eb035c
Muon 4.8.2
OS Release 17.4.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 64.0.3282.140

#5 still not working on Brave v.21.18


I had this issue as well–played with the default settings and found that it’s specifically the “block 3rd-party fingerprinting” setting which breaks the login page. Hope that helps


Agreed- same with mine.


Yes, you are right. Turning off the fingerprinting fixed the problem.


Chase site is still not working for me. I’ve tried the workaround for dropping shields on the first page, then opening the same page again. Also, many variations. All attempts end at the message that javascript is not enabled. Firefox will be my own workaround for the duration, but I am greatly enjoying Brave in general.