Cast targets do not appear on Brave

Description of the issue:
Pressing “Select Player” and then “Cast” does not display the secondary menu containing the Cast objects that are configured on my machine.

How can this issue be reproduced?

  1. Press the Select Player icon (just to the left of the Profile icon on the top row).
  2. The word “Cast” appears; click on it.

Expected result:
The available configured Cast targets should appear in a window, where one can be selected. But I get nothing at all.

Brave Version( check About Brave):

Version 1.31.2.6810

Additional Information:
This works just fine on Chrome, Edge, and Opera but not on Firefox (“No players found”) but I don’t use Firefox except for testing so I don’t need a solution for that.

Over the years this problem has occurred repeatedly in Brave. I have tried a few of the posted ideas and in most cases the advice is not current with Brave’s build, or the recommended flags don’t even exist for me to set. The most recent post I found suggested enabling Widevine. That did not work for me, so here’s yet another post requesting to solve the same problem.

Hello @gdstuart

Thank you for reaching out and I’m sorry to hear you are going through this. Please use guest mode to see if the issue persist and If that works, please try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let us know if that helps.

Alice,

Your answer has nothing to do with my question. Did you perhaps mean to send this to someone else?

1 Like

Alice,

In any event, I tried your suggestion and it did not change the situation. Guest gets the same result (no Cast targets).

I have 17 extensions enabled in Brave. I am not interested in deleting them all and then having to re-add and customize every one of them.

1 Like

Actually, it kind of does. They were requesting you to try this in Guest Mode, which is an option within the browser. The purpose is to see if there was an extension that might have been creating a conflict for you.

Their instructions on removing extensions said to do it only IF opening in Guest Window had worked.

Which icon you talking about? Cast targets are usually on the Cast button, which looks like New Tab - Brave 3_16_2023 12_15_45. Then you also have the Media button, Photos 3_16_2023 12_19_44. I don’t see the words anywhere of Select Player like you mentioned and clicking them don’t have anyone Select Player. So just trying to make sure I’m on the same page as you in understanding.

As for me, I just tested and I have no issues, assuming you’re talking about casting. For example:

Photos 3_16_2023 12_17_15
Photos 3_16_2023 12_16_57

Both areas allow option for Cast to a device and lists my device.

Umm, what’s this? For example, current Brave version is Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit)

So if talking Brave version of 1.31 vs 1.49, you’d obviously be far behind. And if it was supposed to reference Chromium version, obviously there’s a problem there. So can you double check and get back to us on what version of Brave you’re using?

Also:

  • Which version of Windows are you using?

  • Are you connected to WiFi?

2 Likes

I’m on Windows 10. This computer is directly connected to my router (Ethernet).

Here’s the Brave version I’m on:

image

I may have entered the Plex version on my original post, sorry.

So to select a Cast target, I do the following:

image

Hovering over the Cast icon shows the Select Player text. I then click on Cast but get nothing:

image

On Chrome, repeating these steps gets me this display, where I can select a target:

image

I hope my screenshots have eliminated any confusion about this process. I appreciate your help, as well as Alice’s.

1 Like

Ah, on my Windows 11 Pro is shows Display on another screen when you hover. Then of course, once you click it says Cast Tab. So that just goes to show why I was confused on terminology and wanted to verify we were talking the same button.

Photos 3_16_2023 12_57_01

TL:DR version of my reply here: Can you try to connect to same WiFi as the device you’re trying to cast and see if it works?

Longer explanation:

I’m wondering if you might be having a similar issue as I used to have before I upgraded my Windows 10 Pro to Windows 11 Pro. Back then I was trying to cast but nothing was showing. After I bounced around a number of support channels, they advised me I MUST be connected to the same WiFi channel. So if I wanted to cast from Desktop to ChromeCast, I had to have my desktop on the same WiFi. This didn’t make sense as I never had to in the past, but once I connected to WiFi in addition to my Ethernet, the devices showed and I was able to connect.

It’s still an intermittent thing. Like yesterday I went to cast and nothing showed until I turned on my WiFi. But while testing just now as I was about to tell you about it, I noticed the device still appeared and let me cast even with WiFi on my desktop turned off.

It would be weird if Chrome is doing with no issue and Brave isn’t, but if you can test to rule this out, would be appreciated.

I disabled my Ethernet, connected to WiFi, but the symptoms remain the same.

I definitely agree that it’s weird, but maybe we’ll have to go with weird and I’ll just fire up Chrome to cast stuff.

Any other ideas, I’m open to hearing about it. Thanks.

@gdstuart Guess let me have you try two more things, for curiosity.

  1. If you go to brave://settings/extensions and turn off Media Router, click Relaunch, and then turn on Media Router again, does it change?

  2. If you go to Create a new profile within your browser, does it work?

That was it! But when I first looked at the extensions, Media router was not even turned on. I switched it on, restarted Brave, and Cast is now showing the targets.

I never fool with these extensions, so I have no idea how it got turned off. Let’s mark this solved. But it is an obvious setting to check if someone has this issue in the future.

Thanks again for the help.

1 Like

@gdstuart To be honest, I’m shocked you were seeing the Cast button with it off. I assumed that couldn’t be it because when I turned off Media Router, the button vanished. Good to know that’s all it is/was though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.