Cascading windows

Brave is cascading new windows, moving from the original placement down and to the right.

How can this issue be reproduced?

  1. Open Brave.
  2. Open a new Brave window, or close Brave and reopen it.

Expected result:

I was expecting the new window to open in the same position as the previous window.

I would like to disable this. I don’t want my web browser doing its own window management – it’s messing up my alt-tab window order.

Brave Version( check About Brave):

V1.31.88

Additional Information:

What operating system (distribution)?

What window manager?

Linux Mint 19.2 Xfce.

I’m going to install other window managers and see if that makes a difference.

OK.

There have been a lot of threads on here the last couple weeks about Ubuntu, Mint, and maybe others – running Xfce – where there have been issues with window size and placement.

Yours sounds a little different but might be the same underlying (Chromium) problem.

I replicated the problem with JWM. Firefox is OK, and Brave is OK in other window managers. I think Brave might be setting an Xlib mask that is causing this. I’m going to printf JWM and see if I can track it down. (xfwm4 is too complex to debug, at least for me.)

I tracked this down in JWM. Brave is setting the Xlib USPosition (user specified position) and PPosition (program specified position) flags (see /usr/include/X11/Xutil.h). There’s probably a good reason this is being done, but I don’t know what it is. I bypassed these flags in JWM (PlaceClient() in place.c), and things work as expected.

Xfce is also working now, but I didn’t change anything, so I think this was an error on my part. :confused:

If it helps at all, this is the Chromium bug, but I’m not sure if it’s causing your particular issue: https://bugs.chromium.org/p/chromium/issues/detail?id=1261874

I think that’s something different, but I haven’t seen that behavior, so I’m not sure.

For anyone using JWM, cascading can be suppressed by adding this to your .jwmrc file:

<Group>
    <Name>brave</Name>
    <Option>pignore</Option>
</Group>

“pignore” is “position ignore.”

So it seems that Brave tries to cascade windows by default, based on the previous window position, and most X11 window managers either ignore this, or allow it to be disabled. I’m not sure about xfce4 – there may be some corner case that it’s missing, which may account for unexpected window placement.

So, other than this issue, I really like this browser. :slight_smile: