Captcha not loading

Trying to log in to https://www.coinigy.com/auth/login after putting user/pass it says “Please input the Captcha and login again” but nothing appears, having the same issue with https://global.bittrex.com/Account/Login

Logging in Twitch dot tv, it asks as well but the browser asked to allow “Motion Sensors” and after I did I was able to do the captcha.
I enable it in both the other sites I mentioned above, but didn’t work. Tried allowing everything and turning off Brave Shield, didn’t do the trick either, even after cleared all browsing data.

Also in https://account.skrill.com/wallet/account/login after I click LOG IN it just doesn’t do or load anything.

I’m using windows 10, have the latest Brave update Version 1.4.95 Chromium: 80.0.3987.122 (Official Build) (64-bit)

Would really appreciate it if you could look into it.

I was able to see the captcha on https://www.coinigy.com/auth/login just simple tick-box “I’m not a robot captcha” can you re-check this? maybe clear the cookies and reload the page?

Did it, still the same. The only thing left to try, that i can think of, is reinstalling Brave, since I have it from almost the very start. Maybe some updates down the line might have messed with something. I’ll do it if you think might fix the issue

Can you check that your zoom is 100% and double check screen DPI/zoom settings?

both at 100%, don’t think that’s the problem.