Capital One ENO extension


ENO extension thinks every invocation is a new browser access
How can this issue be reproduced?

  1. Install the Capital One ENO extension
  2. Invoke the extension and log in
  3. You’ll receive a email from Capital One about a login from a new device, which is correct.
  4. Next time ENO is invoked, again an email about a login from a new device, which is incorrect.

Expected result:
Only the first login should be identified as a new device the rest should not.

Brave Version( check About Brave):
Version 1.38.119 Chromium: 101.0.4951.67 (Official Build) (64-bit)
](https://brave.com/latest/)

Additional Information:
ENO is a Capital One extension that generates a unique credit card numbers for each website. On other browsers (Chrome, Firefox) I get “a new device login” notification only when logging in the first time. All other times I do not. With Brave though, every invocation, even when I do not have to re-login, generates the “new device login” alert. There is probably some default setting that is different between Brave and the other browsers and I need help identifying and finding out how to resolve this.

There was another request for help from another user that basically went unanswered and was closed after one month. I hope this one will be more successful.

@the1avi

Did you register your computing device? Some websites ask, if you would do so.

In order to ease the network flow and web compatibility . . .

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

Examine all of the settings for all three tabs: Basic / Advanced / On exit

Be as sure as you can be, that the settings are arranged for your use of Brave Browser.

Set: Time range:All time, when manually clearing (using tabs: Basic / Advanced).

Re clearing Cookies and other site data - do that - it is a necessary step when trying to fix website access/rendering problems.

In a Brave Browser > New Window, go to: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows

Remove all: Sites that clear cookies when you close them

In the upper-right-hand corner of the window, notice the Search field. There, enter: capitalone

capitalone_Search_Cookies

Scroll down to: Sites that can never use cookies

Be certain, there, that none of the listed sources for cookies are, or might be, sources related to the bank website.

While still at the Cookies settings page, find: Sites that can always use cookies

Click the Add button

Enter [*.]capitalone.com:443 as the site, but Do Not Enable :

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Next, in a Brave Browser > New Window, go to: brave://settings/content/javascript

In the upper-right-hand corner of the window, notice the Search field. There, enter: capitalone

capitalone_Search_JavaScripts

Scroll down to: Not allowed to use Javascript

Be certain, there, that none of the listed sources for JavaScripts are, or might be, sources related to the bank website.

While still at the JavaScript settings page, find: Allowed to use Javascript

Click the Add button

Enter [*.]capitalone.com:443 as the site . . . but Do Not Enable :

  • Current Private session only

Click the Add button

Next, in a Brave Browser > New Window, go to: brave://settings/security

Disable: Use secure DNS

Do not use a VPN, for connecting to the bank - intending to Sign In.

Use a Brave Browser > New Private Window

But Do Not use a Brave Browser > New Private Window with Tor

Site settings - tip

In a Brave Browser > New Window, go to: brave://settings/content/all

Use the Search field, for finding the existing Site settings for a domain. As a test of searching and finding the specific Site settings, enter: capitalone

The Site settings you see, are the same that result, by your Right-Clicking on the Padlock icon, that is located near the left end of the URL address field, when you visit: https://www.capitalone.com - you would scroll down the resulting pop-down window . . . to the bottom, and select Site settings

Thank you, thank you, thank you! Following your recommendations it seems so far that I got this issue resolved.

I didn’t make all the changes because I wanted to try to see which one will work. So I made the changes in “Sites that can always use cookies”, “Allowed to use Javascript”, and disabled the “Use secure DNS” after which it seems to be working fine.

1 Like

@the1avi

Often, the user is the troubleshooter. Thank you for taking the time, and surviving my method of jump-starting the Brave Browser > Settings Learning Curve.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.