Can't view PDFs in my email client

I’m about to change to Firefox. Have tried everything to get Brave to ‘view’ not download pdf attachments in my email. When I highlight view I just get a circle spinning forever. Shields up/down-no difference. It used to work fine, but a few months ago stopped working and I have no idea why. I generally like Brave, but if I can’t fix this I’m going to change browsers. It’s way too much hassle having to download every pdf a friend sens me in my email.

@diddleyman66 Sadly I’m on my iPhone and getting ready to go to sleep but I happened to check my phone and saw your post here. I remember people discussing this issue in the past and what they said you had to do was change the default program on your computer to where Brave would be your default PDF reader. Once that was done they said it just automatically opened in the browser. Normally I would hop on my computer and give it a shot but I’ll have to wait another time or if you want to test it yourself and get back to me. Otherwise hoping that @Mattches or someone else might be able to swing by with a remedy

Can you please check brave://settings/content/pdfDocuments and confirm that you have the option set to Open PDFs in Brave?



The only setting under PDF documents is the option to download instead of open and the setting is off



The attached is all I get when I open PDF in settings

PDF info in Brave.JPG

I should also clarify that the pdfs are attachments to my email, which gives an option to view, rather than download. This still works in Firefox and Opera , but never opens in Brave.

Can you please tell me what version of the browser you’re currently using? Go to Settings —> About Brave to see this information.


When I went to check this, this is the message I got. What’s up with this?

An error occurred while checking for updates: Update check failed to start (error code 3: 0x80040154).
Learn more
Version 1.5.27 Chromium: 79.0.3945.117 (Official Build) (64-bit)

Oh goodness — this is likely the reason you’re encountering this issue. You are on an extremely outdated version of the browser.

Since the automatic update doesn’t appear to be working, can you please go and re-download the installer and run it? It will not overwrite any of your current data, only apply the latest updates.

Please let me know if you are able to successfully update to the latest build (v1.34.81)

Downloaded the Windows 10 64 bit reinstaller on the link you suggested. Shows version 1.5.27 after taking forever to download and install (more than 30 minutes) . I checked and it shows the same options re PDF as before . same error message as before . I reloaded and there was no change. The only thing this appeared to accomplish was closing about 8 tabs I had open, which I have to try and find again. In addition when I checked Task manager it showed updating 32 bit version, although I twice downloaded what stated to be the 64 bit. I have no problems with my internet connection, plenty of memory including 32GB of Ram on Windows 10 and the computer speed is fine. I’m beginning to think I should just uninstall and try to re-install manually, although I would lose so many bookmarks, last opened tabs, passwords etc in so doing it may not be worth it. This is extremely frustrating! Why it was working fine a few months ago and now is a pain I don’t know. Thanks for trying to help, but this doesn’t appear to have improved matters.

Sorry — you’re saying you went to, downloaded the installer offered, ran it, and your browser still shows v1.5.27?


I assumed it installed. I had to leave after about 30 minutes of waiting while it was still in the process of installing and when I got back and ran Brave all my previous tabs were gone and the install box that had been taking its time was no longer on the screen. I should mention that I also cleared the cache and closed the active Brave while trying to install. Pretty weird that task manager kept showing the 32 bit being updated when the link on the screen that you sent and that I went to clearly stated 64 bit Windows.

Didn’t get any error messages on my home screen when I got home, but when I and opened up that About Brave I saw that same error message I referred to in a previous post. Bottom line it appears to not have really updated the Browser although I got no install error and, like I said above, had assumed, given the different appearance of Brave ( without my open tabs) that it had. I always used to be able to view the pdf attachments in my email under Brave until a couple of months ago and still can if I use a different browser ( Firefox, Edge ,Opera and Chrome have no problem viewing pdfs) A mystery

If I’m being honest, the PDF issue is the least of your concerns when you’re running such an outdated version of the browser. Application updates aren’t just for new features and bug fixes — they also hold very important Chromium updates (the underlying engine that runs the browser) and security updates/fixes. Running such an outdated version of Brave, or any browser, opens you up to a litany of security risks so you should always make sure you’re running the latest build.

That said, I’m not really sure why the browser isn’t updating. Do you have any antivirus applications running in the background at this time?

What I suggest now is that you uninstall the browser, then reinstall from the website directly again. Note that, if you want to keep your browsing data, when you go to uninstall Brave (via Add & Remove Programs in Windows) you will be prompted as to whether or not you want to delete browsing data as well as the app — leave the box unchecked if you want to keep your data.

Once you’ve uninstalled it, re-run the installer and it should, hopefully, install the latest version.


Nope, no anti-virus programs . The only thing I use is Windows Defender and 2 anti-malware programs, none of which have given any warnings. I’ll try your method after saving all my present tab addresses over to Firefox, just in case I otherwise lose stuff.I’ll let you know , hopefully today or tomorrow, how it works out. Thanks


Hallelujah! It works now. Don’t know why it refused to download and install new version before, but I didn’t even have to go into settings to get the PDFs to open! Thanks a lot for all your help. Cross fingers it stays this way


It should stay this way. And just to double confirm — the version you’re running now is the latest build (v1.34.81), correct?

Yep- and thanks again. Now I don’t have to change browsers

1 Like

You’re very welcome.