Can't upload profile or header photo to Twitter

Description of the issue: Using the default navigation, I can’t upload a new photo to the header or profile in twitter. It simply doesn’t open the pop-up window to do it.

Actual Result (gifs and screenshots are welcome!):

Reproduces how often: I’ve tried disabling the Brave Shields and allowing the fingerprinting, it didn’t work.

Brave Version(about:brave): Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Reproducible on current live release (yes/no): Yes

Additional Information: When I tried to do it using the Tor mode it worked perfectly. And I use windows 10

@britodouglas Thanks for reporting. You are on Windows 10 platform if i am not wrong?

Just tried uploading/changing Profile/header pic in Twitter on Released version 0.58.21 on Windows 10. With default shield settings i am able to upload the pics in both Normal and Tor tabs.

Can you try it on the new profile. Also can you share the shield settings screenshot/image?


1 Like

Can confirm that I’m also able to upload profile pictures to Twitter (tested on other social media as well, just to be sure) using default Shields.

I discovered the issue, it was caused by S3.Translator extension, no idea why. I’ve just disabled all extensions and I was testing all.

Thanks for the support.


I had a similar issue. I’m glad to see you found a solution

1 Like