Can't sign in to any website using google sign-in

Just can’t sign in to my services via google sign-in. I used to have the same problem with previous versions of Brave. Then it worked eventually if I clicked a sign-in button lot. With the recent version, no chance.

I do it with Brave Shields down, both on Google and other websites.

**Steps to Reproduce (add as many as necessary):

  1. Go to any website offering Google sign-in e.g. getpocket.com or soundcloud.com
  2. Click Log in with Google or Sign up with Google
  3. A blank window pops-up and immediately disappears.
  4. Still not signed-in.

Reproduces how often: Always

Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)

Even I am facing the same problem

Thanks for reporting @Pgray @gp_brv,

Likely we’ve an issue logged for this. I added your +1 and you can track the progress here https://github.com/brave/brave-browser/issues/2175

Thanks
:slightly_smiling_face:

2 Likes

@gp_brv, @Pgray,
What OS are you guys using?
On Windows I can authenticate with Google sign in without issue. Is there any way I can see a screenshot/vid of this behavior?

I am using Windows 10 with the latest updates.


When I am clicking the BITS Login Button( the one with Google icon), brave is not redirecting me to the Google sign in page, whereas in other browsers it works fine

I was facing the same issue. That’s because Brave block 3rd party cookies (like google’s). When the sign in flow responds back, it doesn’t have access to the cookie validating you’re signed in.

You need to allow all 3rd party cookies in Brave privacy settings. This is not ideal, once Brave supports exceptions list, it’ll be possible to only allow google (even if that’s not great either.)

1 Like

No, mate. I have all shields down both on Google and Pocket. The lion icon is turned gray in both cases.

Thanks it helped. But that means, Brave needs to introduce exceptions list.

@Pgray go to settings and there search for cookies. Then select ‘Allow all cookies’ in the ‘Cookie control’ option

Awesome, thanks.

Well, I would say there is just a bug in the shield feature. If I turn it off, it should allow cookies automatically,

@Pgray
Yeah. Even I encountered the same bug. When I tried to turn to turn down the shield on the website using the brave logo, even I wasn’t able to perform Google sign-in. Maybe we shoul report it as a separate bug.

Yupp. @eljuno ! Hold your horses! :slight_smile:

@jeromegn helped us to discover it’s a bug in the shield feature. In order to sign-in with Google you have to allow all cookies in the Preferences.

1 Like

Set cookies in your Global Shields Settings to Allow all cookies. You may need to allow all from Shields as well. Then, go to the site, login and once authenticated, you should be able to set your cookies configuration to however you’d like.

Yeah, but it’s a part-time solution and a hassle. Thanks anyway.

The above solution should only have to be performed once.
Have you tried?

Regardless, there is definitely a fix for this. I’m able to authenticate using my Google credentials into several websites without issue.

Unfortunately, whenever cookies get deleted I have to enable them (temporarily) again in global settings in order to log-in to Google accounts. It seems that global setting takes precedence over local, in my case.
Version 0.58.16 Chromium: 71.0.3578.98, set to delete local data on exit.

This topic was automatically closed after 30 days. New replies are no longer allowed.

@BrowSir,
The “clear data on exit” setting is a little wonky right now, but have you always had that on?

I am having this very same issue, have set the shields to allow all cookies, and it still won’t work. I am trying to log in to udemy using Google and it just closes the window without logging in.