Can't reconnect into Brave Rewards

I can’t reconnect into Brave Rewards. Brave logged me out and now I have this info since three days. What is wrong with that browser again?

Hey, what region do you reside in?

My region is Europe, Poland

Right now, Poland isn’t supported for Brave rewards verification, so that’s the reason for you not being able to link Uphold/Gemini. Sharing the link for supported me countries below->

Brave is working on getting workable regions back by the end of the year, so you’ll have to wait till your region is supported, to be able to link. You will still earn BATs and you’ll have to claim them each month which will be saved on your device local files. So make sure not to format, clear data or reinstall Brave as that would make you lose your BATs. Hope this helps!
Also updates about this is on the page I’m sharing below →

1 Like

But uphold shows that my account is connected. Last month I have received transfer from Brave.

It must have disconnected like now. It disconnects every 90 days for security reasons.

I don’t know why it’s showing this. I think it must take some time to refresh

They are two different things. Uphold is showing Brave is still authorized from their end to connect and their API is able to communicate with Brave in general.

Brave is showing that they have terminated the connection to your Uphold and needs you to log in again. This is a security feature that automatically logs people out of their Uphold accounts on occasion.

This would be because many restrictions did not go into place until July. If you had been connected while your region was supported, then you would have continued to receive payments. But once you become disconnected again, you’d not be able to connect.

Screenshots like this are awesome. Only thing I’ll say is it makes things much easier if errors/notifications in languages other than English are put into text. It’s a lot more difficult to translate text in images than it is from actual text here.

It seems you’re not getting the “Unsupported Region” message but instead are getting another one that shows when there’s an issue. The problem is it’s a generic error that can mean many things.

Generally, it usually exists when a User has a mismatch of KYC documentation. I know you mentioned you’re in Poland but then like if you ever used a passport or ID to verify as if you lived in another country and you haven’t updated it, then it can display that error. However it can also exist if your browser is not updated, there’s a network issue with Uphold, etc.

What we do know though is if you’re in Poland, you currently will not be able to connect to Uphold regardless.

Oh, and if you want to keep on top of updates, you can always follow my own Topic that SmartyAadi linked to you, which is the “PSA: Unsupported Region” one above. In it, I post updates when we hear them and give at least weekly tidbits of information based on what Brave shares.

My screenshot says. “Your request is still processing, please wait” so I wait 3 days

1 Like

Yea I agree, I had to go and translate in photos💀

Unfortunately, it’s as I said in the prior one. Thanks for at least relaying that just for a confirmation. With your region currently not being supported, there’s no further steps to be able to take. You’ll need to wait for it to be added by Brave again for you to be able to connect to Uphold or Gemini. They are hoping to have this completed by the end of the year, with Brazil and possibly a few other countries being added again within the next few days if all goes well (they are waiting on Uphold)

Just FYI. Today I have received BAT for August to my Uphold.

Yeah, that’s cool. If you recently became disconnected it can sometimes have the one final push to receive. But you won’t receive in the future unless they can activate and you get connected once again.