Can't open links direct from emails


#1

I can’t open links in my outlook emails. Normally, I click on a link in an email, the orange bar in the outlook email starts flashing orange and it takes me to the website in the link.
Since installing Brave, I click on the link, the bar flashes orange but all I get is an “hourglass” going for a while on Brave then nothing.
I tried changing various settings but didn’t help.
It makes no difference whether the link in the email is to a video or just to a website address: I had the same problem when trying to click the link from Brave confirming my account. I had to copy and paste the address.
I have a Windows 7 operating system and am using a PC
My Brave version is:

Name Version
Brave 0.14.1
Muon 2.57.8
rev 3de60d5
V8 5.7.492.71
libchromiumcontent 57.0.2987.133
os.release 6.1.7601
Node.js 7.4.0
Update Channel dev
os.platform win32
os.arch x64

I only installed Brave today

PS I have had to un-default Brave because it is just too frustrating and time consuming but will still use it as a non default browser

VITI


#2

Outlook links the app which is set to default with html pages. So if you don’t have Brave set as default browser it would be impossible to open direct links in Brave.


#3

I’ve experienced something like this with email links, but not sure it’s the same. Many links go to a special tracking address that silently registers your click and then immediately redirects to the real page. Some trackers doesn’t like Brave’s blocking and therefore​ don’t make the redirect. I get stuck on the tracker (non-)page.

Solution 1: Disable Brave’s blocking so that the tracker can track you :wink:

Solution 2: Check the tracker url in the address field. Sometimes the target page’s url is extractable from the query string parameters and you can copy-paste it.

Feature idea: New privacy filter in Brave that circumvents known email click trackers and directly requests the target page (practically doable?).


#4

sriram, I did have Brave set to my default browser but no links would open. It was so frustrating and time consuming I had to go back to Chrome as my default.


#5

Hawkunsh, I like your idea of a new privacy filter in Brave that circumvents known email trackers.

I tried disabling various things in Brave - all that I dared to that is, but it didn’t work.

I did copy and paste, but frankly, it is too time consuming, and that is why I went back to Chrome as my default. Brave really do need to sort this out.


#6

Same issue here. Not only from emails, but any external program.
After clicking a link, the Brave pops up, but does not create a new tab or open the link.

ubuntu 16.04
brave 0.16.13 (set as default)

update:
this is only when the browser is already open. Opening from a link works ok when Brave was completely closed. (- of course I always have it opened…)


#7

I am new to the Brave browser and have ran into exactly the same issue: Can’t open external Links (from Evolution, Telegram etc.) if the Brave browser is already running.

My System:

  • Xubuntu 17.04 Zesty Zapus
  • Brave 0.18.16

#8

I just found another thread where that issue is already known: Brave doesn't open new tabs for external opened websites


#9