Can't make Brave search engine my default home page

I was selected to implement the Brave Search Engine. I followed the instructions and was able to add it as the default search engine in the “Search” field in the address bar. (I use Firefox as my browser.) BUT - I NEVER use that field for searches. My homepage when I open Firefox is my search engine. Currently, that is DuckDuckGo. So - I open Firefox. DuckDuckGo comes up and I automatically use that for my searches. Is there a URL I can enter, to make Brave my home page and, therefore, my default search engine?

I don’t think going to a bookmark is the definition of “default”.
I do the same by the way.
Also, You can save the Brave Search in the bookmark too. I did.
It did expire, but I was able to reset it and the bookmark works again.

I’m not talking about a bookmark. In Firefox, there is a “Search” field in the address bar. I was able to set Brave as the default search engine there. (Although it keeps running me in a circle saying I’m not signed in.) What I’m talking about is the homepage on my browser. Currently, my homepage is DuckDuckGo. So that’s what I’m using for all my searches. To use Brave’s search engine, I need to be able to set that as my default homepage. But I haven’t figured out how to do that yet.

Ok, a home page. Which is like a bookmark.
Is there a Home page in Brave?
I managed to set Home Button to Brave Search and that works.
Edit: You actually want this in Firefox ?!

On the other hand I also could not set Brave Search as default.
I mean I could, it just doesn’t take me to Brave search, it takes me to “Brave Community search”
search1

I can’t even feedback on this as this is in settings and not a search page.

Well, as a reminder, I am not using the Brave browser. I tried it once and couldn’t do all the things I wanted to do, which I can with Firefox.

Hi @KCPhil
EDIT - this is a known issue and team is working to push out a fix soon.

Hi @NotThatSmart,
Can you send a screenshot of your Default search engines list?
Also what version of Brave are you on? If you’re on 1.26.67, Brave Search Beta will be listed as an option here: brave://settings/search

I did an update.
Now I have two, one says Beta the other does.
I don’t know how is it suppose to be, but in the other thread, we fixed it by adding “s&source=desktop” to the end of the link.

I switched over to my old machine.
Started with updating.
Then just went Brave Search (which says beta) but on the list of search engines the Beta is not there.
Also there are % signs in the link so it
s different. Placed there by Brave.

But default works.


just downloaded the latest android update on my tablets and this seems to be resolved

This topic was automatically closed after 30 days. New replies are no longer allowed.