Can't make accounts on various websites

I have noticed that, using Brave, I just can’t make new accounts pretty much anywhere these days. I don’t use any fancy extentions, and I have tried turning off shields. Two recent examples:

PrePaidCenter - Can’t make account. No password combination is allowed, despite it having a capital letter, lowercase letters, a number, and a special symbol. No matter what I try to use, I can’t make an account. This might actually not have anything to do with Brave though.

JackIntheBox.com - Receipt told me I can start collecting points to get free food, so I went to make an account to redeem it. This is what I get:

sorry, something’s wrong http failure response for https://nomnom-prod-api.jackinthebox.com/cognito/create?challenge response=null: 0 unknown error

Tried looking it up, results just give me some complicated technical nonsense. Impossible to create account.

I had to use the internet on my phone to make the account, and I absolutely despise using my phone for anything other then calls and texts. It’s a slow piece of junk that barely loads any website without crashing or freezing.

There are others, that I can’t remember right now. It seems everywhere I go, I can’t make accounts using the Brave Browser. It’s just ridiculous and I have no idea why. Only other browser I use is Firefox.