Can't login to

Description of the issue:

Cannot login to Stake. All cookies and settings are cleared from the toolbar lock icon and I’m running with Sheilds off for site. Privacy and security has been set to the least restrictive settings. Private window gives te same result.

This page isn’t working redirected you too many times.
Try clearing your cookies.

Exact URL of the website in question: redirects to

Did the issue present with default Shields settings? (yes/no)


Does the site function as expected when Shields are turned off?


Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):


Does the site work as expected when using Chrome?


Brave version (check About Brave):

Version 1.50.118 Chromium: 112.0.5615.87 (Official Build) (64-bit)
Win 10

The strange thing about this is I have the password saved from when I logged in months ago.

We are aware of it, a fix is being worked on

1 Like

Don’t want to use Chrome? Try

Seems to be long-running issue:

  1. Error - "xxx redirected you too many times."
  2. All Google apps are unusable

Confirmed working now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.