Can't log into website, no response

Hi, I am having trouble logging into a website. I have a self-hosted nextcloud server that I can log into anywhere except Brave on my desktop. I am able to get to the login page but when I type in any credentials (right or wrong) it does nothing and has no response. The URL gets redirected but the new page does not show correctly and still shows the login page. I would expect it to re-direct me to another page. It appears to just refresh the page. If I type in the wrong credentials, I do not get an error or anything. I am able to login in with Firefox and the mobile brave app so I know it is something on my desktop version of Brave. I have tried disabling all shields and clearing all the cached data. I have had this problem before on other websites and the solution was to clear the cached data but that is not working this time.
I am running Brave [Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)]
Any ideas?
Let me know if I can provide any more information on the issue.
Thank you

Try Allowing all cookies in shields before you login, see if that helps. @bgommel4

That did not work @fanboynz I tried disabling all shields and same result