Can't log into Publishers platform

I’ve been trying to log into the Publishers platform but to no avail. I keep getting the same error:

I’ve tried using a different browser, clearing my cache and deleting cookies but to no avail.

Any idea what I can do to get back in?

It did this for me first thing today but I restarted Brave Browser completely and retried and it was fine after that. Have you tried an Inprivate Session yet aswell as turning off completely Brave Shield?

Inprivate is always what id suggest when having page load / login.


Can you make sure you click the latest link sent in email @misterdarm?

I have tried both of your suggestion but I’m still getting the same error.

I always click the latest email yes I keep getting the same error. I don’t think it’s an issue from my side to be honest. I’m a semi-pro computer user with deeper understanding of computer concepts.

1 Like

cc @steeven @cory for assistance with your creator account

@misterdarm - can you DM the email linked to your account?

Hi @steeven I have a similar issue. I’m not receiving the log in email. I have been trying for the last four days with no success. I’m an old user of brave publisher. Could you help me? I have checked the spam folder just in case. I’m using a Hotmail account. Thanks!

Hi @steeven. Did you manage to resolve the issue? I’m having the same issue now on both my computers.

Hi @misterdarm - Not seeing a DM. Can you send one with your email? Thanks again!

I solved my issue by copying the link provided in the verification email which is sent as part of the log in process. You need to copy this link and open it in a browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.