Can't leave sync chain on macOS

Description of the issue:

I have multiple computers on a sync chain, Mac, Windows and iOS. I updated one of the Mac’s to the M1 version, and sync seems broken.

I noticed that it uses another Sync Chain, so I tried to leave it, to sync with my usual one.
I select “leave sync chain” but when I select back the “Sync” menu, it’s still configured.

Same issue here, but no answers.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Leave sync chain
  2. Open sync chain

Actual Result (gifs and screenshots are welcome!):

Computer doesn’t leave sync chain
Sync settings are always unchecked

Expected result:

Leave sync chain and offers to configure a new one.

Reproduces how often:

Every time

Operating System and Brave Version(See the About Brave page in the main menu):

macOS Big Sur 11.1 - Brave 1.18.78

Additional Information:

Try this Sync doesn't work on windows 10 last version ?

OK, so the answer is :

  • Go to brave://sync-internals
  • Select “Disable Sync” on the top right corner

You can now sync again, or left it disabled

If you sync again, you’ll have that screen in brave://sync-internals