Cant Leave half-broken Sync Chain

Description of the issue:
Hello, I really enjoyed Brave and was happy when the Sync V2 was added, but now when trying to fix something that got randomly broken, I am getting really frustrated.

It all started when I noticed that the main computer (desktop) of my sync chain suddenly showed that other devices were last seen like a month ago ( I have a desktop, laptop and smartphone in the sync chain). I went on to check both of the devices, and the laptop, smartphone see each other as checked in and up to date, but shows desktop last seen about month ago, naturally I thought, that I could leave the Sync Chain form the desktop and rejoin, but when I press “Leave Sync Chain”
I get a browser restart and nothing has changed at all, it is still there. Tried reinstalling brave, searching for similair topics here in forums which remain unanswered. Also I cannot delete the desktop from the chain on other devices, how do I manually remove this computer, there clearly is some malfunction, but no answers this.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
1.Open up Brave settings
2. Leave Sync chain
3. Restart browser
4. Chain is still there
Reproduces how often:
Brave Version(See the About Brave page in the main menu):
Version 1.18.77 Chromium: 87.0.4280.101
Type of devices currently running on the Sync chain in question:
Windows 10 Desktop
Windows 10 Laptop
Android SmartPhone

Additional Information:


I’m having a very similar issue, though in my case the sync data was suddenly gone before I was pushed to refresh the sync chain.

I just started a new sync chain a couple of weeks ago which has been fine until today. On the newer computer (B) the chain suddenly broke, clearing passwords, history and other data. I could not get computer B to re-sync, so I tried removing it from the chain to re-link it. I could only remove it from computer A (the device name for B is gone), but computer B would not remove itself (still shows both devices)

I was able to create a new profile and sync temporarily, but within an hour the same issue happened, logging me out of everything and wiping saved passwords. Same issue with not leaving the sync chain.

I will also note, that on the problem computer (B) even when I click sync everything the toggles in sync data remained off.

Brave Version (same as initial post):
Version 1.18.77 Chromium: 87.0.4280.101 (Official Build) (64-bit)
Windows 10 Desktop

1 Like

I have exactly the same problem with Brave on MacOS, I cannot leave the sync chain.

I started another topic few weeks ago and there is still no response.I’m starting to discern, that support is completely ignoring user reports.

1 Like

I switched to Brave because Chrome’s sync stopped working, now Brave’s sync has stopped working. What is the problem. I’m able to finally leave the chain by going through the Windows registry and removing all traces of Brave, then reinstalling but doing this time, after time, is getting tiresome. Please help us, fix this problem.

I switched to Chrome to resolve this but I was still being logged out of my account periodically. So, I dug a little and found this unresolved Windows bug that leads to logout issues with Chrome

So far the solution that is working for me was to disable the one S4U task I had in task scheduler (Carbonite auto-update.) So far so good for both Brave and Chrome, though I’ll post an update if it breaks again.

EDIT: unfortunately this didn’t work, reverted again this morning.

Update as of 01-15-21: after doing the above and resetting once with the method suggested by @lokan below the issue has stopped.

Same problem here, but on a Mac M1. Can’t leave the Sync Chain.

I see a lot of people regardless the device type is actually having this problem one way or another.
I did not yet try completely removing Brave with all the registry keys as mentioned by @FolsomG10, but I see that this has also been tried and acts as a time bomb anyway.
Would be nice to see a fix from developer side and maybe testing some issues rather than just scouting for workarounds.
Glad to see this topic has caught other users attention, unlike other similar topics I have searched on this, which had no replies and were auto-closed because of that, while containing similar problems with evidence. Hopefully this also catches attention from Brave support.
Once I started using this browser, I did not even need the sync, forgot about it, but once v2 came out, I adapted it and got used to the auto-fills, so it randomly getting broken while already implemented is much more painful than not using it at all.

On the note, I have also tried the flags to disable the Sync and re-enable it, but that clearly does nothing except just soft-disabling the feature, while keeping the Sync chain data anyway.
Users should have a way to remove a sync chain manually at least, even if it gets stuck, because that would be not be the worst thing, as any main up-to-date computer could reseed the info in the new chain…

OK, so the answer is :

  • Go to brave://sync-internals
  • Select “Disable Sync” on the top right corner

You can now sync again, or left it disabled

If you sync again, you’ll have that screen in brave://sync-internals


This seems to trigger the fresh setup state, however, after trying to rejoin my existing chain, I entered the keywords, restarted brave and it created a new chain again, which again could not be left… At this point I am not sure if I should even try adding devices to the new one.

1 Like

@gmobilize I had the same thing here. Tried one time. Created a new sync chain, and I had to disable sync a second time for it to work.
I didn’t restart Brave until after it was successfully setup though.

We will try this. thx

So this works, as a workaround. I still lose sync integrity after 2 days, consistently. I either reinstall Brave, or (now) use the workaround proposed above, every 2 days. In 2 days I’ll let you know if the workaround stuck, or not… thx

Stayed sync’ed for 2 weeks, went down today, used same workaround (a few times) to get it going again. Still happening…

Sorry for late update, had no time to reply, but this seems to have worked in the end somehow.
I only did manipulations you mentioned in the previous post, and repeated the process again ,as with first time it gave me no progress.
Then after second time the main desktop was reinstated in the old sync chain and is now up and syncing for a few weeks now, had no issues so far.
But seems like not all people are that lucky, but i would suggest playing with brave://sync-internals as mentioned by @lokan

disabling sync via brave://sync-internals worked. I was going to lose my mind because the bookmarks kept duplicating themselves after wiping bookmarks and leaving sync chains over and over again.