Can't install the developer builds on Win7

While waiting for a crash bug to be fixed, I got a tip from @LaurenWags about testing the developer builds. I cannot seem to install it though. The symptoms I get are described here: Brave crashes when opening a particular site

I’m running on a 64-bit Windows 7 Professional system and I use the Windows firewall plus Kaspersky Free Antivirus. I have tried without both the firewall and the antivirus though, but still no luck. Is the temporary developer build installer a Win10 only component, or should I expect it to work on Win7 too?


Same symptoms here with Windows 7 on two different machines. Disabled the firewall but still having the same issue.

  • I ran BraveBrowserDevSetup.exe,
  • it says “on your marks…”
  • The next screen appears stating “Connecting to the internet…”
  • The next screen appears stating "Unable to connect to the internet. If you use a firewall, please whitelist BraveUpdate.exe.
  • when checking task manger, it shows BraveUpdater.exe three times.

Original issue from @jek6094 quoted below:

I tried BraveBrowserDevSetup.exe, and it starts off with “On your marks…”, then it says “Connecting to the Internet…” and then it finally stops with an error message saying “Unable to connect to the Internet. If you use a firewall, please whitelist BraveUpdate.exe”… :confused: The process does create stuff under …/Program Files (x86)/BraveSoftware/Update, but when I close the dialog, it cleans up whetever it has created. I do not get a single warning from the Windows firewall that something is trying to access Internet though, so no idea what’s going on.

EDIT: Tried with Windows Firewall off and anti-virus disabled, but still no luck. (same error message) I wonder if it’s a Win7 issue? Maybe the same issue that prevents crash reports from being uploaded?

Hi @jek6094 and @murphy, thanks for reaching out!

We’ve had some issues with the Dev build on Windows 7 machines in particular. We are investigating the problem now and I will come back here and update you with any additional information I find.
Thank you for your support and your patience!


Just wanted to say that the latest published developer build works! I had to disable the anti-virus though, since it terminated my first install attempt, deeming it as “suspicious activity”. :slight_smile: Thanks for fixing the network connectivity issue!

1 Like

Just used the same executable from Friday now and it works! :slight_smile:

1 Like