Can't install LastPass extension in Brave

Description of the issue:
I can’t install the LastPass extension in Brave.
So we have three computers in our home, all running (different distro’s of) Linux.

  1. Our main PC is running Pop_OS! 18.04, Brave (stable release: 0.66.101 Chromium: 75.0.3770.142) and has no problem with installing any extension, including LastPass.
  2. But on either of our laptops, the LastPass extension won’t install.
    Laptop A is currently running Linux Mint 19.2 (but I’ve tried this on Ubuntu 18.04 and Pop_OS! 18.04 as well, with the same result) and Brave (stable release: 0.66.101 Chromium: 75.0.3770.142). All other extensions install without problem, except! LastPass.
    Laptop B runs Ubuntu 19.04 and Brave (stable release: 0.66.101 Chromium: 75.0.3770.142). All other extensions install without problem, except LastPass.

Steps to Reproduce:

  1. Open Brave
  2. Visit LastPass on Chrome Web Store
  3. Click on Add to Chrome.
  4. a crx-file gets downloaded in the download-bar (other extensions aren’t visibly downloaded like this, see image)
  5. The crx-file get’s downloaded to about 5mb (of 12,5mb according to LastPass extension page) and stops
  6. An error pops up stating: There has been an error. Download interrupted.

Actual Result:
well… nothing… just errors and half downloaded crx files.

Expected result:
LastPass extension to be installed.

Reproduces how often:
Every single time, but only on our laptops, not our main pc.

Operating System and Brave Version:
see above

Additional Information:
Tried downloading crx-file through Firefox and dropping it in Brave’s extension-page, but I end up with an other error: CRX_HEADER_INVALID.

Schermafdruk%20van%202019-07-23%2013-35-27

Ok, I don’t know if I should add this here or what b/c I’m using Win 7, not Linux.

I was able to add LP to almost all of my Brave persons except 2. I managed after SEVERAL reloads & tries to get it added to the 2nd to last one, but the last one, nope,

I keep getting this - https://mega.nz/#!IlsiDSxA!xX9gfl7BXA3OWdyhYOwC6zaURM0GmuJvsuGQrTaDg6U

I also Xed out of that Brave person, loaded it again & still nothing, still same error.

Note: I was adding another extension “Nimbus” & I didn’t have issues with that one, so for now I assume this is an issue only with LP.

I was just about to start moving everything from Chrome over to Brave, but I need LP. I can’t live without it as much as I want to switch to another software.

I see no one has responded to this thread & it’s been 9 days.

I also see there’s many other issues with LP.

Are you guys fixing the LP issues once & for all?

Thanks

I’m having the same issue with installing the lastpass extension on Windows Version 0.67.124 Chromium: 76.0.3809.100. I’ve been able to install other extensions but lastpass gives me the Download Interrupted error. I see in that it’s trying to download the .crx file but it appears that it gets a 403 Forbidden error when brave requests the extension file which results in the error seen at least that’s what it says when I right click on the failed download at the bottom of the screen and choose More Information. The 403 error however, maybe related to a bad “More information” link to support.brave.com than to the extension issue. The URL for the broken extension is:
https://extensionupdater.brave.com/service/update2/crx?response=redirect&os=win&arch=x64&os_arch=x86_64&nacl_arch=x86-64&prod=chromiumcrx&prodchannel=&prodversion=76.0.67.124&lang=en-US&acceptformat=crx2,crx3&x=id%3Dhdokiejnpimakedhajhdlcegeplioahd%26installsource%3Dondemand%26uc

I see that there are multiple reports of this same issue starting last April but none have been addressed.



I’ve also had success installing and using the lastpass extension on a different computer with the same version of brave so I’m not sure why I’m getting a 403 forbidden error on this Win10 computer when it works from the same network on another Win10 computer.

This topic was automatically closed after 30 days. New replies are no longer allowed.