Can't install Chrome Extensions

Description of the issue:
Downloads from the Chrome Webstore get interrupted and I can’t seem to install Chrome Extensions anymore

How can this issue be reproduced?
Install Brave, go to the Chrome store, try to install an extension

Brave Version( check About Brave):

before anyone tells me that I need to sign in, I’m signed in to google, and before anyone tells me that I need to download the extension and enable developer tools I did & I can’t download it as it gets interrupted… until the change to 1.5.123-1 I was able to simply login to my google account, go to the chrome webstore, and click add to brave and install the extensions like Lastpass, now i simply can’t do it

1 Like

This has been reported on Windows as well. I’m not sure if the problem has been resolved or if it’s still buggy and occurring intermittently.

@jaybird @kronikpillow,
This issue should have already been resolved – if you’re still seeing this occur, please let me know, but also know that you can simply try to retry the download a couple times and it will take.

Interestingly, tried again today and it worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.