Can't install brave in OpenSuSE Leap 15.1

Description of the issue:
The installation instructions for OpenSuSE on the Brave download page do not work properly. (Note: I had to disable the links in the text below by removing punctuation to post this topic due to this website’s restrictions.)

How can this issue be reproduced?
Follow the steps at https brave-browser readthedocs io en latest installing-brave.html linux, Section OpenSuSE

  1. Install curl
  2. Retrieve the authentication data
  3. Add the Brave software repository to zypper
  4. Install Brave from the repository

Expected result:

  1. (skipped - curl already installed)

  2. sudo rpm --import https brave-browser-rpm-release s3 brave com brave-core.asc

  3. sudo zypper addrepo https brave-browser-rpm-release s3 brave com x86_64 brave-browser
    Adding repository ‘brave-browser’ …[done]
    Repository ‘brave-browser’ successfully added

URI : https brave-browser-rpm-release s3 brave com x86_64
Enabled : Yes
GPG Check : Yes
Autorefresh : No
Priority : 99 (default priority)

Repository priorities in effect: (See ‘zypper lr -P’ for details)
96 (raised priority) : 1 repository
97 (raised priority) : 3 repositories
99 (default priority) : 14 repositories

  1. sudo zypper install brave-browser
    Timeout exceeded when accessing ‘https brave-browser-rpm-release s3 brave com x86_64 repodata repomd.xml’.
    Abort, retry, ignore? [a/r/i] ®:
    Trying again…
    Timeout exceeded when accessing ‘https brave-browser-rpm-release s3 brave com x86_64 repodata repomd.xml’.
    Abort, retry, ignore? [a/r/i] ®:
    Trying again…
    Timeout exceeded when accessing ‘https brave-browser-rpm-release s3 brave com x86_64 repodata repomd.xml’.
    Abort, retry, ignore? [a/r/i] ®:
    Trying again…
    Timeout exceeded when accessing ‘https brave-browser-rpm-release s3 brave com x86_64 repodata repomd.xml’.
    Abort, retry, ignore? [a/r/i] (a):
    Trying again…
    Error building the cache:
    [brave-browser |https brave-browser-rpm-release s3 brave com x86_64] Valid metadata not found at specified URL
    History:
  • Unknown error reading from ‘https brave-browser-rpm-release s3 brave com x86_64’
  • ABORT request: Aborting requested by user
  • Timeout exceeded when accessing ‘https brave-browser-rpm-release s3 brave com x86_64 repodata repomd.xml’.

Warning: Skipping repository ‘brave-browser’ because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data…
Reading installed packages…
‘brave-browser’ not found in package names. Trying capabilities.
No provider of ‘brave-browser’ found.
Resolving package dependencies…

Nothing to do.

Brave Version( check About Brave):
This version was downloaded from the Source Forge web page’s ‘Files’ tab. When started, it displays this warning:

“Hello! This version of Brave is unsupported and can only be used for 10 more days. Upgrade to the new Brave as soon as possible. [Download the new Brave]”

where the download button shows the page with the instructions above (which don’t work).

Name Version
Brave 0.27.3
V8 6.9.427.23
rev 2df8cb1
Muon 8.1.8
OS Release 4.12.14-lp151.28.59-default
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 69.0.3497.100

Additional Information:

Name Version
NAME openSUSE Leap
VERSION 15.1
ID opensuse-leap
ID_LIKE suse opensuse
VERSION_ID 15.1
PRETTY_NAME openSUSE Leap 15.1
ANSI_COLOR 0;32
CPE_NAME cpe:/o:opensuse:leap:15.1
BUG_REPORT_URL https bugs opensuse org
HOME_URL https www opensuse org/

Reproduceability
Always (last two weeks)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.