Can't fill out some forms


#1

I’ve noticed that some forms I attempt to fill out won’t work. The most recent example is this: http://www.cornerstonechatham.org/giving/ - I’ve tried letting my shields down but that doesn’t work. Thanks!

Edit: I’m using Windows 10 Pro, Version 1709


#2

@jffwlkr
No issue on Mac OS X
All fields or just some?


#3

It is an issue for all fields.


#4

I can confirm this issue on Windows 10 Home 64-bit Version 1803 both on the site @jffwlkr listed above and when attempting to enter my login data on faz.net, through the menu that appears after clicking on the login button in the top-right corner. It works normally though when using the more standard login prompt: https://www.faz.net/mein-faz-net/


#5

Windows 7 here and can’t get pop down forms for some bill payment sites and also when trying to manually enter an IP address to block in my site back end using Extrawatch extension. No fun always needing to open another browser to accomplish these tasks.


#6

On sites where you encounter these issues, see if disabling shields helps since some aspects of the forms might be getting blocked in the background. To do this, click on (or press on) the lion or shield icon in the top right corner, and then disable the shields while on the relevant page. This helps resolve most cases!


#7

Of course the shields are totally off in these cases. It’s the first thing to try.


#8

I had tried that too, of course, but it did absolutely nothing. I still couldn’t select a text box


#9

I found the answer:

Disable ‘Strict Site Isolation’ under Security.

Someone offered this advice to me in the BAT Telegram Channel, and it did the trick!


#10