Can't enabled 'Scripts Blocked' for website on Mac

Description of the issue:

Since upgrading to Brave 1.17.73 on Mac, I cannot enable the ‘Scripts blocked’ feature for the following website:

This issue does not happen when running Brave 1.17.72 on an Android 10 phone.

This issue has not impacted any other visited websites to date.

**Steps to Reproduce (add as many as necessary): **

  1. Navigate to https://www.smh.com.au/
  2. Click on the ‘Brave Shields’ icon
  3. Click on the ‘Scripts blocked’ switch

Actual Result (gifs and screenshots are welcome!):

Expected result:

The ‘Scripts blocked’ feature can be enabled for https://www.smh.com.au/

Reproduces how often:

Every time

Operating System and Brave Version(See the About Brave page in the main menu):

MacOS version 10.15.7

Brave version 1.17.73

Additional Information:

1 Like

Hello @brenm

could you send screen shot and have a nice day

1 Like

Hi @justsomeone1,

Here is a screenshot:

I can attempt to record a gif if that helps.

Thanks.

if that happen only in this site could you clear cache/cookies ?

and if that did not work a gif would be awesome and have a nice day and you welcome

Hi @justsomeone1,

Clearing my entire cache and all cookies did not fix the issue.

Here is a gif of me trying to enable ‘Scripts blocked’ for that site:

https://imgur.com/a/XumhfUX

thanks for the gif

try that:

  1. disable all extension and try the site in private mode
  2. go to menu then create a new profile just to test if it work fine there or not

and have a nice day :slight_smile:

Hi @justsomeone1

1. disable all extension and try the site in private mode

I don’t have any extensions installed. Using private mode fixes the issue - I can enable ‘Scripts blocked’ for that site whilst in private mode :slight_smile:

2. go to menu then create a new profile just to test if it work fine there or not

I added another profile via People -> Add Person. Using a second person also fixes the issue - I can enable ‘Scripts blocked’ for that site :slight_smile:

Thanks!

when you cleared your cache did you choose cookies and all time ?

you very welcome :slight_smile:

when you cleared your cache did you choose cookies and all time ?

Yes - I did.

I just found a way to fix it using my original profile:

Brave -> Clear Browsing Data -> Advanced:

Time range: All time
Check ‘Site and shield settings’ and ‘Hosted app data’
Click Clear data

After that I can set ‘Scripts blocked’ for https://smh.com.au

2 Likes

nice well done and have a nice day :slight_smile:

2 Likes