Can't Download, SD Card not Found

Could anyone try rebooting the device once and check?

As mentioned before we are trying to narrow down the issue. This particular issue seems to be a tricky one and we are trying to get it fixed asap.

This is not advisable for any software. You would be not on the latest security fixes.

1 Like

Rebooting doesn’t make any difference.

FIX with this :

1 Like
1 Like

New Brave user and new to community so be gentle :wink:
Also got this prob.
First time I tried to download a file Brave asked for permission to use storage and camera - so I denied.
Playing around with app permissions to try and get it to work I have noted that in Brave settings/downloads, when I toggle “ask where to save files” to Off and then try the download again (which fails with same issue reported), Brave has toggled “ask where to save files” back to On without any intervention. Apologies if this is normal or had already been noted

If you watched my recording you’d know that I’ve already done this. It’s also not really a fix, because since the download reports as failed Android doesn’t recognize that new media was downloaded so it doesn’t show up in any apps unless you rename or move the downloaded media. It’s ultra annoying. It also prevents opening things from the download notification.

Same. Pixel phone. Was fixed once by downgrading chrome but that isn’t working now.

Hi everyone I think I. Traced root cause of issue if you review your version path information by browsing to
Url chrome://version
You will probably see issue I see
Executable Path: No such File or Directory
Profile path: /data/user/0/com.brave.browser_beta … (or no beta if you are in stable non beta version.

I think that Executable Path “no such file or directory” is the issue but I can’t for love of me figure out how to correct it manually. My guess is its installer setting bug can anyone review? Thanks

Glad to see I’m not the only one! I also have had this issue since updating to Android 10. I noticed post upgrade that my old download folder disappeared from my apps. I tried to change the download path to the Google Files download folder instead, but I can’t figure out how to manually change the path for Brave Mobile. (Also, restarting my phone and uninstalling/reinstalling Brave didn’t work and I lost 100+ bookmarks in the process)

Hi sir, can you review my post from day ago, my screenshot shows probable error
and I just discovered more information that I think will help.
If you test going to url
Chrome://version and scroll down it has Executable Path: "No such file or directory"
and the profile path shows the long path (which phone itself can’t see) as /Data/user/0/com.brave.browser_beta/app_chrome/default (of course the _beta is missing if it is normal app), but both apps have same “sd card not found” errors.
Thus that Path might be Incompatible with phone itself, for example if I use the Astro File Browser, The location shows a path of
/Internal Storage/Android/Data/Com.brave.browser_beta/files/download/ Which is strange - since each directory past the data root, has NO brave files (other than 5 Random times trying to download a file in the last week has randomly “worked”

Also of note, there is the normal “Download” directory for phone itself still exists under Path /Internal Storage/Download (in my case I have a few hundred MB of files transferred from my old phone.)

**Aha I think I found problem yes - its the profile path, **
So within Brave settings it is showing following without quotes, Download Location
"Downloads /Storage/Emulated/0/download"
So we have a missing /, and a space after the s in Downloads before the rest of the directory and it doesn’t match anything I have - see below

after I Checked box to see hidden files, through file manager Astro I was able to find where actual second directory is
/Internal Storage/Android/Data/com.brave.browser_Beta_Test/Files
Which has yet a 3rd “Download” directory in it thus is
/Internal Storage/Android/Data/com.brave.browser_Beta_Test/Files/download
which has the same duplicate files from the first physical path I found through ASTRO,
/Internal Storage/Android/Data/Com.brave.browser_beta/files/download/

Whats more interesting is the “SD card not found” Error is wanting a plural - “DownloadS” folder vs the “Download” folder I have found three of on the phone up to this point and just as I was about to send this information I searched phone for just “Download” and also found

/Internal Storage/Android/data/
*Empty no files

I also tested adding “Downloads” folders under each of the following one at a time, no luck.
/Internal Storage/Android/Data/com.brave.browser_Beta_Test/Files/
/Internal Storage/Android/Data/Com.brave.browser_beta/files/
also tried to add “Downloads” folder under the
/Internal Storage/ Directory
/Internal Storage/Android/ Directory, and
/Internal Storage/Android/Data/ directory - one at a time and testing NO dice.

I was unable to find the actual Brave .apk files even with setting Astro which normally has not let me down, to see hidden file mode.

I think this wasn’t the problem.

Here is a a screenshot of the latest Google Chrome. It is exactly under the same configuration as what you’ve said.

The only difference is that Chrome does download and Brave does not.

This is ridiculous from brave support team. Users facing this problem since months, still no fu. Solution for this crucial feature.

This issue will be fixed in the next release. We have a beta release out in case any one wants to check it. You should be able to install it via Google Play Store. Or you can download it via GitHub. Please give it a try. You can install both Release and Beta and use it simultaneously


Brave Beta 1.5.116 fix it. Thank you, Brave! I appreciate your hard work!

It’s been almost a month since I post this issue.

Thanks for the confirmation @namapengguna. This ones been a tricky issue for sure.

1 Like

What’s next stable release? Current it is 1.5.9, which stable will follow beta 1.5.116?
Cheers and great work getting the fix

We don’t have a fixed number for the version that would be released yet. If you are on 1.5.9 you should be getting the update pretty soon once its released

1 Like

I can confirm so far a few days of testing this issue has been Stable: using the latest beta release 1.5.116, Chromium 80.0.397.149, Android 10, Sm-G988U Build/QP1A.190711.020 Also known as
The Samsung Galaxy S20 Ultra 5G running on Sprint network.
What a mouthful, to say.

Going to close the thread as the release is out. You should be able to update it soon. Should show up automatically or you can visit playstore and update it manually.