Can't Download, SD Card not Found

Pixel 3xl user here with a question…

Is this so called “…/emulated…” Storage folder normal storage location for brave? I thought it was always downloading to the default downloads folder before this… Only had this happen to me after recent Android update… However I do not know the exact time table… After some (possibly?) unrelated errors with the phone I had uninstalled and reinstalled brave many times to try to resolve and or reproduce issues… Upond reinstallion of beta and standard brave browsers the problem corrects itself but after so many downloads to default folder without issues( sometimes pictures, music and videos, but maybe related to file sizes or total download capacity?) i encounter the error again… Without fail… my internal memory seems to be functioning normally with almost entirely free storage space… Manually attempting to change file download location upon prompt will offer no alternate locations… Where is this emulated folder and how can I access it?

The new OS update really effed things up for not just Brave but other apps too. Same saving issue here on the S9+.

install1.5.5 you can find as a apk file, never update, will avoid this, until the problem go over.

It’s just a temporary fix.

I’m raising awareness regarding this problem. The update 1.5.9 or Beta 1.5.109 still did not fix this. I gave up Brave. Download is a crucial part. In a long run, you do not want to keep using obsolete browser.

1 Like

thanks but how am i to install apk ? i seem to have found apk files with different archetectures but not sure which one is the appropriate one thanks for the tip. edit: i have not been able to find an appropriate apk architecture for my phone, apparently my phone is the aarch64 architecture, is this the right label? sorry to post dumb questions. trying to research where i can find these apk files on the web

I found a temporary solution from Bromite community - they have same issue too - Allow Install unknown apps (Settings - Apps - Brave - Advanced - Install unknown apps - check to allow it, if you need specifics).
Download starts normally but the notification shows an error message but the file is downloaded without any problem.

1 Like

Yes, this works… Thanks…

Thanks, I don’t get the error message. My downloads work again as normal.

installing 1.5.5 by apk file didn’t cause the problem, and I found updated to 1.5.9 by Google play today , without any problem.

Hello, I’ve been having the same problem as well.

Samsung Galaxy S9+
Android Version 10
Brave Version 1.5.8

Problem still persists in Brave 1.5.9, Android 10.
Anybody knows if the developers are even reading this site?
I realise there are bigger issues in the world right now, but this problem has been open for 4 weeks, c’mon

this fixed it for me - thanks.

This essentially brings it back to pre-Android 10 behavior, where it says there is an error, but the file actually downloads.

Same here, it seems everyone has android 10 in common.

What worked for me:
I uninstalled it with app ‘sd maid’ you can try other utility like ccleaner or in-built security app, so that there are no leftovers Then install brave again.
Yes l updated MIUI to then I started having this problem, it was first time I had this problem but not anymore.

We are still trying to narrow down the root cause of the issue. It seems to be a combination of Android 10 upgrade and Chromium update which may be causing the issue. I see the issue happen on clean install only after clearing browsing data but that seems to be one of the scenarios where the SD card message is being thrown. I’ve logged an issue for this and hopefully we should be able to find a fix for it. Here’s the issue for reference


Download BRAVE BROWSER 1.5.5 and do not update it. It works

1 Like

Is there any update, just because of this issue I am forced to use Chrome on my mobile instead of Brave. Its a shame that even after so many customers complained Brave has not yet released the Fix for this. I use Samsung S9+ and ever since I updated to 1.5.9 version this issue is there on my mobile. I can’t download anything. It keeps saying SD card not Found.
There should be a feature to downgrade to older version which Brave does not provide sadly.
Please update us when this fixed. Please release the fix soonish before loyal customers like me decide to use some other browser.


Could anyone try rebooting the device once and check?

As mentioned before we are trying to narrow down the issue. This particular issue seems to be a tricky one and we are trying to get it fixed asap.

This is not advisable for any software. You would be not on the latest security fixes.

1 Like

Rebooting doesn’t make any difference.

FIX with this :

1 Like