Can't download dictionary spell check

I am encountering the same problem on a fresh install. Trying to download either English (Canada) or English (US) dictionaries from settings produces the error:

Spell check dictionary download failed.
Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave Software servers.

Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

Hosts file is clear, have tried disabling firewall. System language is English (Canada) on Windows 10.

2 Likes

Hey @orreryo,

By the looks of it, there is nothing on our side to fix this issue. Let’s hope Aa-ron will speak with the team about this problem so they can fix it. Cheers man.

2 Likes

Same problem here, on a fresh install of the OS and the browser

Trying to download the Brazilian Portuguese and English (United States) dictionaries.

Brave info

Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) unknown (64-bit)

Package info

brave-bin 1:1.10.97-1
AUR Link

Error Message

Spell check dictionary download failed.
Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave Software servers.

hosts file

127.0.0.1 localhost
::1 localhost
127.0.1.1 arch.localdomain arch

System information

Linux arch 5.7.5-arch1-1 #1 SMP PREEMPT Mon, 22 Jun 2020 08:10:02 +0000 x86_64 GNU/Linux

1 Like

Hello. I’m having the same issue here on a fresh install of win 10 pro and latest version of the browser.

I’ve just installed Brave…and there is not an operational spell checker…I’ve been following along, clean hosts file…same error as everyone…so this issue has not been resolved? I don’t want to delete the Brave install, but if it cannot use a spell checker, what the heck else is there to do?

Just noticed I’ve got this issue also

Same problem here.

image

image

same issue, hope they can solve it, we can arrange a remote session if it helps

Yep, same issue here :frowning:

I tried all the steps above and nothing resolves the issue.
I guess we’ll see how quick Brave Support are at addressing community issues.

I can hear a Brave Tech now… “why don’t hey just bloody learn to spell!” …lol :slight_smile:

Anyway, hope the fix comes soon. Have to use Firefox ATM for website Posts as it’s spell check actually works.

I’m not sure if this helps or not as to why it’s not working.

I noticed that if I type into the Google Search Field the Spell Check works even though it tells me the D Spell Check download failed.

I use Microsoft Word and Outlook on Brave and the spell check works there as well.

If however i type a post on FB, or search in Youtube or Tweet on Twitter then the spell check doesn’t work. I’m guessing that Word and Outlook might have their own spell check working even though I’m on the Brave browser, but not sure why Google search field is working with the spell checker?

Anyway, thought i’d add this info just in case it helps to figure out what the problem is.

Cheers :slight_smile:

@NeedHelp1,
Are you using a VPN or any anti-virus software?

Same problem. Can´t install spanish neither english langauges. Windows 10 64x 2004, Host file clean. Fierewall is configured to allow Brave to has acces to both, private and public networks.

Same problem here. I’ve tried all suggested fixes. None work. Will go back to using Chrome till this issue is solved. Besides the spell check not working, I really like the program.

@fglaya
@Bryan3569
Are you using a VPN or any anti-virus software?
If so, can you try disabling an re-adding the language/dictionary?

No, I don´t have neither VPN nor antivirus. I used to have a VPN but I uninstalled it long ago.

Hi Brave community and team! Just installed the browser last week and I’m really liking it, but I figured I’d add my two cents. I’m also having the same issue. Here are the details.

Brave:
Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

Windows:
Windows 10 1903

Language:
English (United States) - plus others

Error:
Spell check dictionary download failed. Please check with your network administrator to make sure that the firewall is not blocking download from Brave servers.

Triage/Troubleshooting Performed:

  1. Cycled through different languages to attempt to download them
  2. Off VPN - Turned off the firewall on my machine and attempted to download spell check again
  3. On VPN - tried to download spellcheck with firewall turned on
  4. On VPN - with firewall OFF, tried to download spellchek
  5. Disconnected machine from home network, used mobile phone to USB tether and used the mobile network to attempt to download the spell check (did this with firewall on/off with the same results).
  6. Same as step #5, but also turned VPN on my mobile phone while it was acting as a USB tether and tried to download spellcheck
  7. Last note - HOSTS file is default on this machine, but I tried with an empty HOSTS file as well and the results were the same.
  8. Last LAST note - no antivirus other than windows defender present on the machine. Turning it off made no difference.

Suffice to say that all attempts of the troubleshooting failed.

I’m not sure what servers Brave is using for spell check so I can’t say if there is a connection or firewall or routing problem somewhere. That being said, I thought about trying something like Wireshark to see what’s happening with the packets but that seems like a bit too much effort for a Friday evening and I’m not sure I would know enough to be able to figure out what’s happening even if I had the logs.

Let me know what other info might be helpful.

Has anyone here tried re-installing? And if not, can you try and let me know the results?

I tried twice and nothing changed.
Tried once on the Linux I said some days ago and once on my windows machine. Sadly I don’t have it right now, so I can’t send you the host file and the browser data

I have an update for everyone here - the team is aware and is working to resolve the issue.

1 Like