Can't collect ad rewards, tip, or auto-contribute

Hello! For the past month or so, Brave Rewards has been completely broken. I didn’t receive my ad rewards this month, and I haven’t been able to tip or autocontribute my BAT to publishers. Every time I open Brave, the Rewards icon has a notification and an error saying “There was an error processing your contribution.”, but I don’t get any other errors besides that.

Here’s what my panel looks like:

My auto-contribute page:

On known Brave publisher websites, it doesn’t even show the Verified Partner badge on the Rewards icon:

I’ve tried reinstalling the browser, and clearing all my browsing data, yet the problem persists. Any suggestions?

2 Likes

Apologies if bumping is frowned upon here, but anyone able to help me out? Brave Rewards is currently completely unusable for me. Should I try contacting Brave staff by email?

@Keatzee,
Thanks for reaching out. Can you please tell me what OS you’re using, as well as what Brave version you have installed at this time (Menu --> About Brave)

I’m using Windows 10 64-bit, and my Brave version is Version 1.5.113 Chromium: 80.0.3987.149 (Official Build) (64-bit)

Hey @Keatzee - try to verify your Brave wallet with Uphold, as it looks like you haven’t done so yet. Let me know if that fixes the issue for you.

2 Likes

Thanks @Asad, I just verified my Brave wallet with Uphold. Oddly enough, I gained 30 BAT in my wallet, however nothing else has changed. Attempting to withdraw funds doesn’t seem to work either. Screenshot:
image

EDIT: I just realized that the amount of BAT in the Rewards panel (from clicking the icon in the address bar) is different than the amount in brave://rewards. Compare the first and third screenshots in my first post and you can see what I mean. Perhaps the Rewards panel is bugged somehow?

Sorry for the second bump, but nothing I’ve tried has worked so far. I’m considering manually deleting all Brave data on my PC and reinstalling fresh, but I just want to make sure there’s no easier fix before it comes to that. Restoring all my settings, extensions, bookmarks, etc. would be a huge pain.

Sorry for the late response!

Try disconnecting and reconnecting your Uphold account to your Brave browser (From the screenshot you linked it looked like you hadn’t connected it at all, which will definitely keep you from withdrawing). This often fixes the issue.

Same for me. When will this rewards UI nightmare end?

@Asad I tried that awhile ago and didn’t really help. It seems to be a problem with Brave Rewards itself.

I found a half-solution on my own a month ago; I ended up linking my Brave Wallet to Uphold and deleting most of my user data in %APPDATA%/Local/BraveSoftware/Brave-Browser/User Data to see if it would fix it. When I reopened the browser and logged back into Uphold, my wallet synced, and most things seem to be working alright. I still get errors saying “There was an error processing your contribution”, but tipping and auto-contribute still seems to work okay, most of the time.

However I’m not able to tip to some Brave Verified Publishers. I get the following message on the Rewards panel:
image
When I go ahead and tip them anyway, my Rewards summary says:
image
This happens with around 50% of Publishers, some of them work completely fine. I’m able to tip to all publishers just fine on my phone. Kind of a strange bug.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.