Can't claim tokens due to "prove you're human" bug

Description of the issue:
When attempting to collect monthly rewards from ads, I cannot proceed because the “Prove you are a human” test does not recognize the correct answer. Very similar to this bug reported on GitHub a while ago: https://github.com/brave/brave-browser/issues/1780 . The animated GIF there depicts what’s occurring for me, too.

How can this issue be reproduced?

  1. When rewards from ads are available, navigate to chrome://rewards/
  2. Click the orange “Claim” button that appears in the upper right. An “almost there… prove you are a human” test appears that requests you drag a logo to the appropriate target. Do so.
  3. A “Hmm… not quite” message appears, and a new test appears. The error then repeats no matter how many times it’s attempted

Expected result:
To successfully claim tokens when the logo is dragged to the correct target.

Brave Version( check About Brave):
[Version 1.2.41]

Additional Information:

@Philo,
When performing the test, can you ensure that your view isn’t zoomed in (or out) to any degree? That is, it should be set to 100% (default) – we’ve had issues with the test when the viewport is anything but default.

1 Like

Confirmed that it isn’t zoomed in or out.

The usual magnifying glass does not appear when I’m on the Rewards page. To double check, I hit control-+ , which zoomed me in to 110%, and then I hit reset zoom, reloaded the page, and tried again. Still got the same behavior – the test doesn’t recognize that I dragged the logo to the correct space.

1 Like

@Philo,
Do you have any other custom set DPI or resolution settings for your monitor? I’ve reached out to some team members for additional ideas as well.

Ah, that’s it!

No custom DPI or resolution settings were made, but I do have the Dark Reader Chrome extension enabled. When I visited the Rewards page, it didn’t appear in dark mode, and the plugin said that the page was “protected by the browser”, so I thought it didn’t have an effect. But I tried toggling the extension off, tried claiming the rewards again, and it worked.

Thanks for your prompt help! I think it’s resolved now!

@Philo,
No problem – glad that it was an easy fix! :slight_smile: