Cant claim Bat on Android

Hi there,

So I have been using Brave on my android phone for quite some time and my current issue is I cant “Claim” the bat I earn.
I press at the triangle at the top left corner and then press “Claim”, but the “loading wheel” just keeps running in circles, nothing actually happens.

I have tried to go on Wifi, Restart my phone and so on, but nothing works.
I have yet to claim bat succesfully even once.
My phone is a “Oneplus 5” and I am running Oxygen OS 9.0.4 - Android version 9.

I hope you guys can help me out.

Best regards


Hi @Shamatix - thanks for reporting. Have you recently claimed a grant on the same device?

No, I have never been able to claim anything as it wont let me… it just circles around forever untill I give up lol:P

Same issue here in Android. Not possible to claim, loading keep going and nothing happens :confounded:

1 Like

I see you have previously replied to this Can't claim BAT tokens 4 months ago but the thread just got closed? Doesnt seem fixed at all as I have yet to meet a single android user where this actually works.

1 Like

Same problem here.
I’ve never been able to claim my BAT on my Android device.
Same behavior, indefinitely spinning wheel.

OnePlus 3 / Android 8 / OxygenOS 5.0.4

1 Like

Same here but one plus 3t/OxygenOS 9.0.6

Had the same problem on Oneplus 3 using LineageOS. Issue was the Safetynet check for ctsProfile failed.
Fixed it with:
- Install Magisk (Safetynet check should say ctsProfile: false and basicIntegrity: true)
- Install MagiskHide Props Config Module and the Busybox Module
- In a root terminal use the “props” command and follow the steps to change your device fingerprint to a valid one from the list (Onplus 3T Android 9 in my case)
- Use Magisk Hide to hide from play services and brave
- reboot -> Safetynet Check should work for ctsProfile
- claiming the rewards works now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.