Can't Block Twitter Cookies

I’ve been blocking Twitter cookies for over a year and only recently they seem to have circumvented my blocking. I have manually added the following to the sites that can never use cookies:

twitter.com ; www.twitter.com ; mobile.twitter.com

I’m using Brave version 1.41.100 and boy do I want those cookies blocked.

Thanks.

@threesx3,
Do you have your Shields settings configured to “Block all cookies” for Twitter?

It was set to block cross-site. I changed it to block all cookies and the same four cookies keep reappearing.

To clarify, these cookies reappear after being deleted (with Shields set to block all cookies)?

Correct. I delete them, restart the browser, go to a twitter feed, scroll a bit and then get the forced login. Then I check my cookies and there they are.

Quick update… I changed the advanced controls under Brave Shields to “aggressively block trackers and ads” and my Twitter cookie headache is fixed.

Thanks Mattches for your replies a ways back.

1 Like

Ok. I was wrong. Twitter cookies are back. Brave just can’t block them. So frustrating.

Odd. These two things have nothing to do with each other.

Do you see any twitter cookies in it brave://settings/siteData. Look deep into it, you will find something which can link from where these cookies are coming from

Go to brave://settings/socialBlocking and deselect twittter embedded tweets (orange to grey).

Also, if you are that annoyed with twitter cookies and you are just using twitter for surfing without login in, you can use https://nitter.net. It is privacy frontend of twitter which can be used with no cookies, no javascript etc.
https://github.com/zedeus/nitter