Can't access fmylife.com (Cloudflare error)

bug

#1

I have been using Brave as my primary browser, at work and at home (I am a web developer), on MacOS, and Android. I love it.

But I cannot access one of my go-to sites: https://fmylife.com

Whenever I attempt to access the site, even with shields off, I get a cloudflare error message claiming that the host is not responding. I haven’t noticed an issue with any other sites I commonly use, even when they are Cloudflare customers.

I can access the site normally through other browsers without issue.

If there is any additional information I can provide for troubleshooting, I’m happy to help.

Location: Denver, CO
OS: MacOS 10.13.5 (17F77) and Android (5, 6, and 7).

Other than that, I’m loving it. I’ve been actively evangelizing it to others.


#2

@coyote The CloudFlare message is letting you know that the website isn’t available. I test on an isolated machine I have and indeed the site works but there is an issue.

PROBLEM: Site is not configured for HTTPS

Solution: try the site without HTTPS - confirmed working with other browsers.

-Issue persists with Brave even without HTTPS everywhere being enabled.

example http://fmylife.com - works but you have to manually remove the S.

Hope this helps you out @coyote


#3

Apologies for the delay in replying.

I indeed tried accessing the site via plain http, including disabling the http anywhere stuff. No dice. It still redirected to the https version of the url, and gave me a cloudflare warning.

Oddly, it works fine on my android tablet and phone. Just not in the MacOS version of the browser.

I’ve found that if I do the following, every single time I visit the site with MacOS Brave, I can view the site properly for that visit:

– Visit the http version of the url. It will redirect.
– Open the brave menu, and select Shields > Site Settings…
– Disable Http Anywhere.
– Reload the page.
– Wait for it to redirect to the https version of the site again.
– Open Shields > Site Settings again.
– Disable http anywhere again.
– The site will then automatically reload with the http version.

This is a little awkward, and it doesn’t carry over for future site visits. I have to do this every time. I have to assume this is a bug, not a feature.


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.