Can't access banking sites

I’ve just set up my new PC with Brave. My old one had Brave also, working quite well, apart from occasionally allowing Youtube to play ads. Now with my new PC, I can access my bank’s home page, but it shows beside the URL “Not Secure” Seriously, this is a major bank, pretty secure I would think. Never had an issue with the old PC running brave, and on this PC, no issue logging in using Firefox.
I have already tried resetting individual page permissions, turning off virtually everything to do with security, but when I enter my log in details, the site times out.
I’m nearly over it, and about to put up with unwanted ads via Firefox, for the mere convenience of using sites I choose to use, rather than “Computer says NO”

1 Like

Hi @Carlsworld
Can you confirm if you tried reloading the page but with all cookies allowed enabled.

1 Like

Hi Aa-ron. Thanks for the reply.
Have this showing, and closed down the browser, even rebooted the machine, and same result. Have just noticed it says the site certificate is unknown.

1 Like

This just rolls for about 10 seconds, then it times out. The log in page comes up after selecting “Proceed to ANZ (Unsafe)” in the warning page. Same machine, Firefox browser, and the loading circle barely does one entire rotation before I’m in.

1 Like ? Seems incorrect, it should be either or How did you get to this page? @Carlsworld

1 Like is the home page, the log in link goes to the above, (minus the .au) both in Brave and Firefox. Firefox is however, successful in logging on at that same address, without the .au appearing. Nothing fishy there, or the problem. It starts with the attached pic, and clicking the red text to change permissions, shows that all permissions suggested, and even more permissions that I’d like to allow are allowed.

Do you have any anti-virus or firewall? if so, which?

Maybe clear the site settings of open in private mode.

The warning that you have to click through suggests a bad certificate along the way. Those are often injected by anti-virus, firewall or parental control software.

Can you go into brave://settings/certificates and copy the list of certificates that you see in there under “Authorities”?

It’s a long list, so probably better to copy it as text since it would otherwise require a lot of different screenshots.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.