Cant access a website, problem with ad blocker on certain website

Hello, simple problems: cant access this website: - shows: ERR_SSL_PROTOCOL_ERROR

Second thing. On this website: adblocker popup sometimes appear to disable adblock. When I disable it (click on the icon → deactivate shields) and refresh the website 6/10 the popup will come back, if I then start brave in incognito mode (ctrl shift n) and paste the link, and then disable the shields, popup doesn’t show up.

Please fix it, because for me those errors are the reason I have 2 browsers now.


It looks like the site only opens from Europe, with Brave shields ON.
On my side (Outside Europe and USA) I used a VPN (europe) to manage to access the website. Also, when I tried a VPN from USA, it doesn’t open.

Page worked fine here, but there is a good chance its checking your IP (and cookies) if you’re in a different location. Clearing cookies, and using a VPN would be a good check here.

Well, thanks for all the help - I decieded to go back to Chrome where those websites work fine. Also, the new hide cookie conset thing is completely broken and it breaks most of the sites I visit. To be honest - there is zero support for this browser and I don’t have time to fight with things that works just fine elswhere.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.