Cannot verify wallet ongoing issue

Briefly describe your issue: For a couple of weeks on mobile (android, Samsung s20) I have been unable to verify my Uphold account. I have contacted Uphold and they asked me to contact Brave. I click on ‘Verify’ then it takes me to the Uphold application on my phone. I click on ‘reauthorize Brave’ and it comes up an error saying something went wrong, try again later (screenshot attached).

What Operating System and Brave version are you using: Android, Brave 1.35.101.

Is your browser wallet currently verified: On desktop PC yes, on my mobile phone it was but it won’t let me reauthorize it.

What date did you verify your wallet: On desktop today (12/2/22). On mobile a week or two ago

Have you been able to successfully receive payments in the past: Yes

Are you using a VPN? (yes/no): No

Are you in a supported region for list of supported regions): Yes Australia.

Does your device pass the SafteyNet check (Android only): Says ‘Failed’, ‘Can’t access Google Play Services’.

1 Like

I am also not able to verify. It authorised but says it is in process and “verify wallet” never disappears

I have the same problem as well. Here are the screenshots

Hi, the solution to this problem is to uninstall uphold and then try everything again and hopefully it will work.
It worked for me.

1 Like

Good morning,
Thank-you for your reply. I tried this and it did not work. Any other suggestions? I have contacted Uphold and they have passed the buck onto Brave. If this is not resolved I am likely to move to the DuckDuckgo browser.
Kind regards,

@Darkninja89 Based on what you showed, it won’t work on mobile because it can’t pass SafetyNet. Usually the “can’t access Google Play Services” is due to a phone being rooted. Either that or you don’t have things completely updated. Not sure if you want to check app and Android versions for any update. It could also help to clear cache for Google Play.

Not sure what else as I’m not all that knowledgeable around it. I’m going to tag @fanboynz to see if he has any ideas or can try to refer to someone who could. I mean, possible Mattches or Steeven could help but I also know they tend to be lost in helping the tons of people having issues with BAT payments, lol.

Thank-you for your reply. I checked both the version of Uphold and Brave in the Google Play Store and it seems to be the latest version. My phone is locked to Optus as I am on a postpaid plan but I have not had this issue before. Is there anything else I can try or should I wait for a response?
Kind regards,

I guess only thing while waiting is to have to research like crazy on things causing issues and get it to the point of passing SafetyNet.

What’s agitating is I never really see people respond to that when Mattches or Steeven ask, then posts get closed. I tried researching your specific error and most of it suggested the device would be rooted, which prevented issue. The only other one from Google was to clear cache from Google Play. I didn’t see anything else on it.

And there are times when people respond, but then Steeven never helps. Such as you see at Displays the following message: Oops, Something is wrong, Please try again later - #3 by emo82

I’m wishing I could learn more on some of these things, but sadly learning as I go while trying to help with issues here. In the meanwhile, I just know I had been talking with Mattches and Steeven on trying to help more. What they told me is they just want people to DM them with information and then to be patient. It’s just the two of them working on things for the most part and it can take a while to resolve each issue for people.

Mathematically, I’m not sure how that works as it means they’ll definitely never catch up. I mean, if each individual ticket/DM/request can take anywhere from a few minutes, to a few hours to several days to diagnose., it’s quite interesting. Especially when they also said we have 1000s of messages to go through between us (support),


Can you please confirm whether or not you uninstalled, then reinstalled the app? If so, can you please try uninstalling the Uphold application, then instead trying to verify/authorize using the Uphold website in the browser?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.