Cannot set Brave browser as default in macOS


#1

macOS High Sierra version 10.13.1
Brave 0.19.95
rev cc0ebad
Muon 4.5.16
libchromiumcontent 62.0.3202.94
V8 6.2.414.42
Node.js 7.9.0
Update Channel Release
OS Platform macOS
OS Release 17.2.0
OS Architecture x64

I recently started using Brave and like it enough so far to make it my default browser for a while. Previously I had Chrome set as my default. Brave asked for the honor, I agreed, and told the other browsers to stop complaining about not being the default anymore. I thought all was well until I clicked a link in another application and the browser that opened was Safari. Safari was not even my default browser before Brave. In the image above you see the Brave preferences screen with the macOS System Preferences window on top of it. Notice that Brave does not even show up in the list of browsers that can be selected as default. That is weird, but I also have several other browsers installed that also do not show up in the list (Firefox, Opera). Just for kicks I opened up two other browsers and that must have jarred something because now Brave and a bunch of others decided to show up in the list. Perhaps this is not a Brave bug and instead a macOS bug. Either way, I thought I would share it in case others have this problem. Brave is now receiving URLs from other applications.


#2

Have you tried setting it to default again?

Opening Brave preferences and scroll down to the bottom:


Click the orange “Set as default” button at the bottom.


#3

As I said, I am no longer currently having this issue, so I cannot test this. However, if you will notice in the first image I posted, the Brave browser already thought it was the default browser, just as it does not, which means there is no “Set as default…” button.


#4

Gotcha. Well, glad the issue sorted itself out!


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.