Cannot select files on websites - Windows 10

Description of the issue:
On any website, in private window o not, if I want to select a file on my computer : I click on a button, the file chooser pops up, but then the file selector window instantly disappears.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go on a website that let’s upload files (for example wetransfer). Click on “Choose File”.

Actual Result (gifs and screenshots are welcome!):
The file chooser/selector opens, but then instantly disappears.

Expected result:
I can choose a file on my computer.

Reproduces how often:
Every time. It worked well before but has been happening for several days now.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Version 10.0.19042 Build 19042
Brave Version 1.23.71 Chromium: 90.0.4430.72 (Official Build) (64-bit)

Additional Information:

1 Like

Hello @pmorange

close brave and make sure it does not work in the background then right click on brave icon then run as admministarator

let me mention @Mattches that the 5th post that has same issue with the latest version on windows

all other post solved by run brave as administartor

so not sure what make that permission issue

and have a nice day both of you :slight_smile:

Hi @justsomeone1,

EDIT : Spoke too quickly, it seemed to work and now I am experiencing the problem once again…

@pmorange,
Do you have any extensions installed at this time?

I have the following ones yes :

  • Keeform (since I installed Windows and Brave a few months back)
  • SurfShark (VPN, but not activated)
  • MyJDownloader

@pmorange,
Just to test, would you disabling all your extensions temporarily and test and see if you get the same behavior afterwards?

1 Like

Really weird.
The problem was happening this morning as it has been for the last few days. Since then, I was using Edge to upload files. But suddenly it began happening in Edge too.
Now, to test in Brave, I disabled my extensions in Brave. And the file selection got to work once again !! So I enabled the extensions one by one, restarting Brave each time, to see which one could cause the problem. I got to enable all of them again, and now it is working with all of them enabled.
As for Edge, stop, start, and working again.

So I have no idea what could be causing the problem to tell you the truth.

maybe you updated brave and that last update fix it as yesterday there was new version released

glad to know it work fine now

@pmorange definitely glad to hear it’s working. Yes there is a good chance that whatever you were encountering was resolved by yesterdays browser update.

Don’t close the case too quick, it is still happening :smiley:
But it also happens on Edge at times so it’s more complicated…

[EDIT] If I close the browser and open it several times, it happens that sometimes it works again, so this is kind of a workaround.

@pmorange,
I can check and see if this is known Chromium issue, which would explain why this issue is hard to resolve.

Version 1.25.68 working for now.

1 Like