Cannot save any kind of file, photo, PDF etc

I just logged into my bank and tried to export my statement several times unsuccessfully and reported the problem to my bank but then tried to save various other files from other websites and had the same problem. The option is there as a contextual menu item but the actual save dialogue box does not appear and the files are not saved to the default location either.

Brave was updated yesterday or the day before and the last item I had previously saved was two days ago so I assume that it is related to the update.

I’m using Brave Version 1.16.75 Chromium: 86.0.4240.193 on Mac OS X 10.15.7

The Brave icon in the Dock had a badge with 9 on it which I thought may be the number of downloads I had attempted. It was annoying me so I rebooted Brave to see if it would clear the badge, which it did and I seem to be able to download again.

I don’t know what happened but I had rebooted Brave after its update a couple of days ago.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.