Cannot open community.brave.com links on the background from an external source if "Block 3rd party cookies" is enabled

Description of the issue:

Can’t open community.brave.com links from an external source if “Block 3rd party cookies” is enabled.

Steps to Reproduce (add as many as necessary):
1. Open this Reddit post which contains links to Brave forums I preferred the look of the original brave browser to the beta. : brave_browser
2. Open a link in the background. This happens https://i.imgur.com/6yHvzvv.png
3. Open a second link of another similar URL but this time by left-clicking and opening it in a new foreground tab. That one will load properly. Close both tabs.
4. Try opening the second URL on the background this time. This time it works, because you’ve opened it on the foreground before. From now on, that second link will open properly until the browser is rebooted.

Reproduces how often:

Always, until the link is opened on the foreground at least once.

Brave Version(about:brave): Can’t open about:brave or chrome://brave/ it says ERR_INVALID_URL

Reproducible on current live release (yes/no): I don’t have it installed.

Additional info: The problem is made worse by a bug in the shied settings which makes it unable to remember shield configuration after a browser restart. If I flip the cookie setting to “Allow all cookie” and reboot the browser, it will be back to “Block 3rd party cookie”. Could it be related to this Un-blocking all scripts one-by-one still breaks a website until the general Block Scripts is disabled · Issue #1358 · brave/brave-browser · GitHub

Hi @smartfon,

I’m unable to reproduce this on my end. Are you using the Beta or Dev version? Also, if you go to Settings (3 dots on the top right), the last option in the menu should be “About Brave”. You can click that to get your Brave information.

By what method did you open the link in the background (#2)?

Beta version. Version 0.55.11 Chromium: 70.0.3538.35 (Official Build) beta (64-bit)
Windows 10 1803. Dell i5577. Intel 630HD iGPU running the latest drivers from intel.com

I haven’t had this particular issue until today. Few days ago, something updated in the browser and several other problems were introduced, such as some of the YouTube thumbnails not playing on a mouse-hover, and the BAT icon appearing on all websites (first time I’m seeing this icon) https://i.imgur.com/yytEvMr.png

When I started Brave yesterday, it said that the last session wasn’t closed properly and it restored the tabs that I properly closed during the previous browsing session. This is when the aforementioned issued first appeared.

Edit: I open the link on the background by clicking the middle-mouse button.

The BAT icon in the URL next to Shields is there intentionally. It provides easy access to rewards information by way of extension.

Youtube thumbnails won’t play if you have the Autoplay function blocked. Settings --> Privacy and Security --> Content Settings --> Autoplay :

It’s strange that you’re connection is showing up as “Not Secure” in your original post. I’m actually unable to visit the site without a secure connection. Testing again on my end with the following steps:

  1. Open fresh window in Brave Beta
  2. Visit https://www.reddit.com/r/brave_browser/comments/9lfcbj/i_preferred_the_look_of_the_original_brave/e76hxxn/
  3. Open Community link in background (middle-click)

These steps should produce the page/image you linked to

My results:
bgcheck

The auto-play on YouTube is enabled. Most of the thumbnails work, but some have begun showing a white play button instead of auto-playing. It could be a problem on YouTube’s end, but since it coincided with this issue I thought I’d mention.

When you open the link, try letting it fully load on the background before switching to it. Here is what Fiddler proxy shows when I open a link on the background. I’m not using a custom DNS provider. (the highlighted entry is when I opened the URL on the background) https://i.imgur.com/2ScTuPn.png

The links don’t open from Google searches either. Once the link fails to load on the background, after I switch it to foreground and highlight the URL bar and hit enter to reload the page, it will load properly. But if I just hit the refresh button, it won’t load. I have to select the URL and hit enter.

I’m starting to think Chromium’s latest modification to how https is displayed (or lack of thereof) may have some role in here. Why? When I highlight the text manually, it could automatically insert the https part. It is there when I copy/paste the URL, but not visible while in the URL bar. I’m thinking if I highlight it, it could insert the https part on its own and hitting enter will load it with https in place. Meanwhile, hitting the browser’s reload button may not insert https. Just a theory.

I just removed all cookied and data for all sites, and the behavior has changed. Now the links won’t open even if I left-click to open them on foreground. They only load when I highlight the URL and hit enter.

Fiddler shows that upon opening the URL, the only connection that’s being made is to a service worker here https://community.brave.com/service-worker-b3132ce44c958878a3dc19776072ad3861a661ca983e3c8f0269c27a439d47d2.js

I’ve also tried disabling Automatic Tab Discarding from Flags, and removing HSTS cookies for brave.com and community.brave.com by querying them here, then removing the domains from the DELETE field below chrome://net-internals/#hsts

Looks like this issue is growing. Thanks for all the sleuthing!
Hang tight, I’m going to see if anyone on the team may know what’s going on. Will reply back here soon.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.