Cannot install Brave Dev and then Beta and Stable in same computer

I installed Brave Dev first from the website. Then trying to install stable and Beta from Brave website. But I got error message saying that I already installed Brave browser (which is Brave Dev).
In another laptop I have I have Brave (Dev, Beta, RC) all running together at same time. But now it is not possible in second laptop. Is anything changed? Or how to pass this error message?

I am guessing the installer installs everything in same path or so. For chrome I could install canary and one of regular or beta at the same time as they get installed in different directory. brave was working that way earlier I guess, but now something got changed.

Windows 10
As it turned out now, after removing every bit of brave from my laptop I am trying to install Brave Beta or RC (to change the install order so that always the latest candidate gets installed last) from getting the same error message (you have more recent version of brave installed). I could only install Brave Dev now and no other versions of Brave.


cc @Mattches for help to diagnose this issue.

@nellaiseemai, looking into this now.

Would you be able to run try something on your end? Slightly involved but would help us diagnose the issue. If you’re on Windows, do the following:

  1. Navigate to your C: drive
  2. Create a file called BraveUpdate.ini and save it there:
  3. Insert the following text into the BraveUpdate.ini file:




  1. Launch Brave Beta (or which ever build you’re attempting to install)installer and run setup

There is a chance that this alone will resolve the issue. However, if it does not, it will produce a log file in the C: drive (BraveUpdate.log iirc). Send me the contents of this log file and I can have the team attempt to diagnose the issue.

Let me know if you need additional help or if any of this is unclear.

Looks like it solved the issue partially. Thanks a lot.

Just to be clear this is what I did.
I found I was not able to create a folder in C:
So I created a text file named “BraveUpdate.ini” and copied the texts you have given in desktop and then moved it to C:
Now I downloaded Brave Beta from and installed it. Now no error appeared as before (I have Brave Dev already installed) and I could install and run both Brave Dev and Brave Beta side by side.

But when I try to install regular/RC from I was not able to install and presented with same error. Found the log file stored as OmahaUpdate (dont know why this name) in a folder called C: foo. Is this what you are looking for? If so, I have sent you a message please check.

Windows 10
Thanks again

Thanks @nellaiseemai! Really appreciate that.
Glad we at least got Beta working. Let me take a look at the log file, hang tight.

1 Like

I want to test the release candidate from here - Releases · brave/brave-browser · GitHub. Is there a way for that now? or do i need to uninstall Dev and Beta. Currently I get the same error as before.
Not so urgent. But just wanted to update you on this.

From what I’m gathering this seems to be an issue with the stub installer packaged with the test candidate you’re looking at and Windows.

cc @sriram for more information on this.

@nellaiseemai If you install from any of these links Release / Beta / Dev you should be be able install them side by side without any issues. You won’t be able to install any RC builds on windows since the stub installers always point to the latest release so even if you download that stub and try to install it will complain that you have a higher version installed. This is a known limitation on Windows. For other platforms you should be able to install the RC build and use. For Windows you will need an installer which points to the RC builds. Unfortunately this is only internal testing now and once we have standalone installers available you should be able to install RC builds manually and test it.

Hope this clears the doubts. Let me know if you still have any other questions regarding this.


After uninstalling all Brave versions I had (Brave Dev and Brave Beta) and removing all files related to Brave, I tried installing Brave Release from here:
But I still get same error (although I do not have any Brave version installed now as all are removed) “This computer already has a more recent version of Brave…”. This tells me that something left in my computer which the Brave Release identifies and generates this error. But when I am trying installing Brave Beta ( and Brave Dev ( no such issues.
This was my original topic of this post. @Mattches suggested a work around only after that I could install both Brave Beta and Dev otherwise I could only install Brave Dev and getting the same error for Brave Beta as well (not now after the work around).
I sent @Mattches the log file earlier.
I am on Win 10.

I think this might be an issue with corrupt registry entries.

Please note the following steps should be done really carefully. Only try this if you are comfortable modifying registry entries

  1. Uninstall all Brave versions from machine
  2. Open regedit
  3. Verify you have the entry HKEY_CURRENT_USER\Software\BraveSoftware
  4. Verify you have sub entries for Release/Beta/Dev (depending on what you had installed)
  5. Right click on HKEY_CURRENT_USER\Software\BraveSoftware and click Export
  6. Save the registry entry
  7. Right click on Computer\HKEY_CURRENT_USER\Software\BraveSoftware and Delete
  8. Verify if you have entry under \HKEY_LOCAL_MACHINE\SOFTWARE\
  9. If you have follow the same steps for Export and Delete
  10. Verify if you have BraveSoftware entry under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\
  11. Repeat the same steps for Export and Delete
  12. Ensure each export has different name
  13. Search for registry entry for BraveSoftware by pressing F3 button, you shouldn’t have any entries after you have deleted. If you find any other entry follow the same steps of Export and Delete
  14. Reboot and install and you should be good to use different channels simultaneously

Thanks @sriram I will try that over the week end.
But is this problem specific to me, because you said that Release/Beta/Dev can be installed in parallel?

@mattches of late, I am getting this error message frequently for Brave Beta or Brave Dev kept in my task bar which suggests me that during some update cycle in the background something happened to the Brave installs. The browser got totally removed or inaccessible. Thanks
Note: The Brave browser versions I was using before (Dev and Beta) were installed from GitHub pages (long before they got their place in the homepage. So you may be correct there are some registries left over which is causing the earlier errors. Then I wonder there may be some in the forum who must be using those versions from GitHub pages for a long time now were they also getting errors (or similar errors)?

This is an issue with shortcuts. This is not Brave specific this a windows feature to remove unnecessary shortcuts which points to an application that is removed from machine. This message comes for all apps that are pinned to task bar where it can’t find the associated application.

My point was I did not remove Brave Beta myself. I have both Brave Beta and Brave Dev installed but now I have only Brave Dev. Brave Beta got uninstalled itself. Dont know what happened. These are the left over files of Brave Beta in my win 102018-11-01_11-54-52%20(2)

@sriram can you guess what went wrong with my installation? I am going to try the solution you have given. I just want to confirm with you that if I dont go through this steps (registry edit) there is no way I could install stable channel?