Cannot get rid of "Aw snap" page

Description of the issue:
For months, I’ve been trying to get rid of this issue that has made the browser unusable for me. No matter what I do or try, nothing fixes it. I uninstalled it, went into the registry and deleted anything referencing Brave, rebooted, downloaded Brave again and installed it. All the shortcuts and everything else are still there. It’s like it was never gone. I’ve never seen anything like it. This is happening to me on two Windows 10 systems; exactly the same, and my brother had the same issue and went back to IE because I couldn’t give him an answer on how to fix it.

How can this issue be reproduced?

  1. Install it and try to access anything. Nothing works anymore.

Expected result:
I expect web sites to load normally like they do on every other browser I have installed on my PCs.

Brave Version( check About Brave):
No idea. Clicking ‘About Brave’ doesn’t display anything. Same goes if I click on anything in Brave. I assume the latest version as of today as I just downloaded it from Brave to install it yet again with no success.

Additional Information:
I believe I’ve tried everything i could find on this site relevant to the issue.

Can you clear the cookies and cache, then disable Hardware Acceleration, possibly disable all extensions. . Then Restart the browser?

I am unable to clear the cookies and cache. The browser doesn’t really work at all. One of the first things I wanted to try was disabling the extensions. But like I said, I can do anything aside from launch the browser and see all the sites I had loaded when it last worked.

I’m having the same issue. I’ve been hearing about Brave for months and finally decided to give it a shot. Installed it, and on first open, I get the Oh, Snap page. Tried private page, same thing. The browser is completely unusable right out of the box. I can’t even get to the settings page (chrome://settings/), so it’s not like it thinks I’m trying to hit some insecure network or something; even internal code won’t load.

Oh, that’s interesting - in my browser, the URL bar shows brave://settings/, but when I copied and pasted above, it translated to chrome://settings/. Is that normal?

Hey @EmmyS @rbear as a test, could you try installing Brave in a new profile. No extensions, no imported settings. (so completing clean) Does the “Aw snap” issue show?

Try to reset your internet, it worked for me on chrome.

That WAS a new profile. It was literally the first time I ever downloaded it; there were no extensions, no imported data or settings, no nothing. Immediately upon finishing the install, it opens to the Oh Snap page and won’t load anything else, even the settings.

Its not that uncommon on Chrome/Chromium pages. Can be caused by a few issues.


Hi, @rbear and @EmmyS. You can find out the version of a non-functioning Brave in Command Prompt by going to C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application> doing a dir listing.

C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application>dir
 Volume in drive C is Windows
 Volume Serial Number is [REDACTED]

 Directory of C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application

03/04/2020  08:23 PM    <DIR>          .
03/04/2020  08:23 PM    <DIR>          ..
03/04/2020  07:40 PM    <DIR>
03/04/2020  02:53 AM         1,993,360 brave.exe
03/04/2020  07:40 PM               398 chrome.VisualElementsManifest.xml
03/04/2020  02:53 AM           713,360 chrome_proxy.exe
03/04/2020  08:23 PM    <DIR>          SetupMetrics
               3 File(s)      2,707,118 bytes
               4 Dir(s)  109,330,096,128 bytes free

In the above example, the version is, as you probably figured, but Brave shortens this to 1.4.96 in its on-board report and in the release channels and such.

Here are two things that might get rid of the Aw Snap thing.

  • If you don’t have passwords and bookmarks stored in Brave, delete the Brave-Browser folder in your user\AppData or back it up if you do have stuff stored then delete. The folder to kill is in C:\Users\USERNAME\AppData\Local\BraveSoftware\ and is Brave-Browser (add -Beta, -Dev, or -Nightly if you’re using one of the other channels).
  • Disable hardware acceleration. You can do this by
    • editing a shortcut to Brave so the target includes "C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --disable-gpu
    • You can also try via Command Prompt by issuing start brave.exe --disable-gpu

My Brave browser now works on both my PC and laptop. No idea what to chalk it up other then Microsoft’s latest patch Tuesday updates. That’s what I believe broke in the first place. So after months of not being able to use the Brave browser, it’s back working again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.