Cannot connect new brave wallet to compound finance

Hi everyone,
I don’t get it how you can connect brave wallet to compound finance .
When i open compound, you click connect wallet and then it asks you if it’s metamask or others but not brave wallet
And by the way, compound doesn’t recognize brave wallet to connect .

Can you please help ?

1 Like

Brave wallet is fork of metamask in some ways. So click connect wallet on compound, click on metamask, and then connect to brave wallet. Make sure if you have metamask extension to turn it off as not cause any problem for connection.

1 Like

I’m having the same issues with another couple of protocols like MOBOX and some others
I’ve already clear the cache tried to import the previous version of the wallet , but now all of my protocols connected are a mess… having a lot of issues, if it connects to one protocol then another doesn’t works…

I tried that but that doesn’t work

Ok i found one solution …don’t know if it’s the best but works …
In the settings …wallet …Default cryptocurrency wallet…i changed from "brave wallet ( prefer extensions) to brave wallet and then when i type connect wallet …metamask …it connected with compound finance …
See what’s next …

I tried that, but the closest thing to a solution is to activate in default cryptocurrency wallet is to use crytpo wallet (deprecated) and some of the dapps work but not all of them. now having issue with pancakeswap…

FYI - Brave Wallet is no longer a fork of MetaMask but it is compatible with it.
If it is not in some case though, then we consider it a bug.

1 Like

What you might be seeing is a cookie problem since the old wallet was connected but the new one is not. Could you try:

  1. Switching back to the new Brave Wallet
  2. Restart the browser to ensure Cyrpto Wallets is no longer loaded
  3. Clearing cookies for that site
  4. Reload the page
  5. Connect to the Dapp

If that doesn’t work please let me know what the error you see is. Thank you!

Yes i did that and i finally succed in connecting .
Now i had my trezor connected to the wallet , went on compound finance and initiated a swap of the CDai on compound to USDT …The process went through but my CDai are still on compound .

Could you check that please

That looks like a dupe of this one Problem with the swap in the wallet so I’ll close this one since it was more for connecting.