Cannot claim BAT on Android

@steeven 1.060 BAT. No, I am still unable to claim it on my device. I am also unable to verify my account because I cannot claim any BAT :frowning:

I’m facing the same issue, last time @steeven manually transferred BAT, facing same issue in this month as well :disappointed_relieved::slightly_frowning_face:

Also, now it’s showing two Claim buttons, one for last month and another for this month. Not able to claim any one of them.

1 Like

You need to verify with an uphold account in order to claim BAT for the desktop version. I had faced the same issues before, you need an uphold account for that to work.

True. I had this problem for the past 5 months now just waiting for @steeven and the support team to fix it.

How do you do this? How did u get support to help? I’ve been trying to get help for months.

Yeah I contacted the support but the problem is still there and I haven’t get a response from Brave team. It’s been awhile know I am just waiting for them to fix it, this issue’s had happen to too many users. If can try DM and email the Devs and ask them to fix this issue. It’s been way too long :pensive:

I have my account perfectly verified since September 2020 that I do not receive any BAT…
they should have better support at least try to fix it … from what I see it happens to a lot of people

1 Like

Are you on a rooted/custom rom by chance?

Nope my device is not rooted as same as many others. I think this had to do with the operating system of the device and the OS compatibility. Because I had an older device, maybe the version of brave is not compatible with my device because this works for some ppl and not working for some. I was hoping maybe they will fix it through software :upside_down_face: . But the problem persisted for so long I am not sure when this matter is gonna get resolved :frowning:

I use LineageOS 17.1 and I finally figured out my problem. I was failing safetynet checks because of the root and modified operating system.

I saw someone on another thread mention custom Roms as the issue, I thought to myself maybe there is a verification that needs to happen. Found the safetynet solution and I was able to claim my BAT instantly.

I’m having same problem android (not rooted). Cannot claim BAT. I can click on it, but when the page refreshes, the claim button appears again, but never transfers to the wallet.

I also have the same issue, has someone found a solution yet?

I can confirm that you do not need to verify with an uphold account in order to claim BAT for the desktop version.

Once BAT is claimable, it can be claimed into the desktop wallet, it just cannot be transferred out without a verified Uphold wallet.

Could you elaborate on the safetynet solution that worked for you ?

I have magisk and it has a feature to check safetynet. Since it was failing I followed a YouTube tutorial and it worked. Pretty simple just install 2 things and reboot

2 Likes

Could you post the tutorial, could help a boat load of people here with the same issue