Cannot add custom asset Brave wallet

Cannot add custom asset into Brave wallet – the “Add” bubble doesn’t become clickable even though I am plugging in what I believe is all the correct information. See screenshots.
1

Can you do it this way

1 Like

Hey @jbk110, happy to help!

It looks like you are attempting to add a SPL token but you have Ethereum Mainnet selected for the network. Please try this step again but change the network to Solana Mainnet Beta and it should work! :pray:

And if it doesn’t add, I just tested what was linked and it will work. So going to coingecko, typing in ELON for the coin, then hitting Add To MetaMask will prompt for Wallet and then add it.

Dogelon Mars Price in USD_ ELON Live Price Chart & News _ CoinGecko - Brave 11_17_2022 23_57_44

@DouglasHDaniel Just FYI, that’s not even an option. I just went to see if I could manually add it.

VRA Verasity in Brave Wallet - Brave Wallet (Self Custody) - Brave Community - Brave 11_18_2022 00_04_46

Captures 11_18_2022 00_05_24

Nothing at all listed for Solana Mainnet Beta or anything Solana, really. This is in my Brave Wallet on Version 1.45.127.

Maybe mine is just funny and OP will have no problems. I just wanted to point out this little factoid in case anything is being overlooked.

@Saoiray is Solana enabled in your brave://settings/wallet/networks pref?

You may need to create a Solana account before this is visible.

This add’s the asset for Ethereum Mainnet, it looks like @jbk110 is trying to add the asset to Solana Mainnet Beta based on his screenshot.

Yep, I believe so.

@Saoiray do you have Solana disabled in brave://flags ?

I’ll check. Just FYI, mine is running primarily on default. I don’t tend to switch flags. More particularly, I tend not to do much with crypto so don’t usually touch things in Wallet. I just go in to check things for others.

And yeah, seems it was transitioned to Disabled. Is this something that comes Disabled automatically and Users need to know to Enable? Like I said earlier, I wouldn’t have toggled typically. So curious how it did get Disabled if it’s not so by default. :man_shrugging:

That said, enabled flags and just tested, now all the Solana things show up.

Anyway, I appreciate the assist on that. And hopefully it will help @jbk110 a bit in case they are in a similar situation, so they’ll be able to get everything added.

Gotcha!! Yeah was trying to figure out if there was another bug happening. :sweat_smile:

Solana was enabled by default back in April https://github.com/brave/brave-browser/issues/22348 so not sure why yours was disabled.

Every flag rolls out as default as far as I know, wether the default value = disabled or enabled so if it show disabled it would have had to manually been set to that value. :man_shrugging:

Either way, glad you are rocking Solana in the wallet now! :slight_smile:

2 Likes